PDA

View Full Version : Crash Steamversion 0.9



UsF
04-11-2014, 09:05 AM
I wanted to post my crash log, since I seem to be the only person having issues from within my group of friends while we play. Here is the logfile. Maybe it is a memory issue, since the usage appears to be really high.

http://en.file-upload.net/download-8807747/2014-04-11_195426.zip.html

Knil
04-11-2014, 09:07 AM
95% memory in use seems to indicate a ram issue. How much RAM do you have? The game uses a little more than a gig in use.

UsF
04-11-2014, 10:03 AM
I have 6GB of RAM with 1.5GB that was in use by Firefox at the time. Other processes were insignificant.

Knil
04-11-2014, 11:44 AM
Very strange indeed, maybe the new version v0.10 doesn't have this issue for you?

UsF
04-11-2014, 11:58 AM
Thanks for the reply. I will try again soon and if I do not write anything new, the problem will be solved from my part. I will also run a memory usage monitoring program next time to keep track on how much the software uses so I have more data in case of a crash. http://www.berserk-games.com/wp-includes/images/smilies/icon_smile.gif

UsF
04-12-2014, 10:26 AM
We tried to play again and my game crashed. The memory usage of the Tabletop Simulator is 3.5GB. Version is 0.10 on Steam.
http://imgur.com/n825TBR

The game seems to constantly grow in memory usage for me while it is running. Seems to be around 1MB per second.

Knil
04-12-2014, 10:59 AM
The game shouldn't be using more than 1.5 gigs of RAM something is definitely off. The growing memory definitely points the issue to a memory leak. Have you tried running the game in different videos settings or fullscreen or window mode? I'll see if I can find anything on my end.

UsF
04-12-2014, 11:26 AM
Seems like in Fullscreen mode, the memory usage does not grow when I tab out, but it still grows when I am playing and have it on fullscreen. Other than that I have only used Ultra and Very High, nothing lower yet.

Knil
04-12-2014, 11:33 AM
Try playing in a window mode it might be a temporary solution to the problem.

UsF
04-12-2014, 12:04 PM
No in Windowed, it constantly grows, even if I tab to another window. I might have to try a lower graphics setting below very high, but I do not think that makes a difference.

UsF
04-12-2014, 10:53 PM
It seems like the memory usage only increases when I am either in a singleplayer or multiplayer game, but not while I am in the menu. Starting in the lowest quality setting seems to change the memory gaining, but it starts me out at a lower memory usage by default. On the lowest setting, I gain 5MB per second.

If you have anything you want me to do or check, let me know. http://www.berserk-games.com/wp-includes/images/smilies/icon_smile.gif

Edit: I just did a Windows Update to install the latest 7 updates I was missing and now it seems like the issue is gone! If it happens again, I will post again. http://www.berserk-games.com/wp-includes/images/smilies/icon_smile.gif

UsF
04-14-2014, 09:31 AM
The happiness was premature unfortunately. It still happens when I play online games, but doesn't when I play solo. http://www.berserk-games.com/wp-includes/images/smilies/icon_sad.gif I have no idea what is happening and do not have similar issues with other games. Please let me know if you need more information to solve this. The problem did not occur in the earlier versions of the game, though I deleted them all when the game went on Steam. It did happen with the one before Steam though, I think.

Disconnecting from a server resets the memory usage to ~1.6GB.

Edit: Now it happens in Singleplayer as well. I have no idea what is causing it anymore. http://www.berserk-games.com/wp-includes/images/smilies/icon_sad.gif

Edit2: Sorry about the confusion. I just thought the issue was solved and so happy, but it appears that it is still happening. I do not want to spam the forum post with reply after reply so my last suggestion would be that I could offer to show you a livestream of the behavior that I have with the game, if that helps. Hope you read the edits and hopefully the issue can be solved. http://www.berserk-games.com/wp-content/sp-resources/forum-smileys/sf-cry.gif Would it be possible to download an older version, like below 0.7 I think, to see if the issue happens there now, too? I am sure that I had no problems earlier when playing for a few hours.

Edit3: I found old versions, still had them backed up all the way to version 0.3 The issue now appears to be present in any of them, so I assume it is a local issue with my PC. Do you know which vcredist-versions are being used by Tabletop Simulator so I can repair any prerequisites that might be needed?

Edit4: Currently trying to see if it is maybe related to the D3DOverride tool that forces VSync. It randomly happens/doesnt happen right now and as I wanted to show it to some people, it didn't occur. I will edit the post further if I find something new or make a new reply if I find something major.

UsF
05-09-2014, 07:12 AM
My issue has been resolved. I am not exactly sure what solved it though, but I am happy that I can now play without issues.

Knil
05-09-2014, 07:36 AM
A very strange issue indeed, glad it's working!