Page 10 of 10 FirstFirst ... 8910
Results 226 to 238 of 238

Thread: TTS Mod Backup tool

  1. #226
    Quote Originally Posted by daagar View Post
    It appears that all mods that have links to photobucket will fail (specifically, the JJMark album which is used by a growing number of mods). An example link: http://i1374.photobucket.com/albums/...psf7aa4181.jpg
    I'll have a look at it!
    Edit: I just uploaded version 1.8.28 that fixes photobucket links
    Last edited by Froghut; 02-12-2017 at 03:35 AM.

  2. #227
    Quote Originally Posted by Froghut View Post
    I'll have a look at it!
    Edit: I just uploaded version 1.8.28 that fixes photobucket links
    Rockstar. Thank you sir!

  3. #228
    I realize my last post was long and had multiple quotes, so I want to point out that it contains a bug report regarding the "Clean Up" function, that is, it's looking for a "Chest" folder that appears to be named "Saved Objects" now.
    edit: Additionally, renaming "Saved Objects" to "Chest" and hitting the "Clean Up" menu item again simply seems to freeze the program. It does nothing, responds to no input, and has no CPU, disk, or network use, eventually needing to be terminated by a process manager.

    I hope this doesn't seem like attention-seeking. I don't want that report to be missed, and it seems pretty easy to miss, sneaked in there as it is.
    Last edited by Corrodias; 02-15-2017 at 06:24 PM.

  4. #229
    I did "Download all thumbnails", and they are in the thumbnails folder (named with the mod id, not the full name) but they aren't showing in-game. Any ideas?

  5. #230
    @Corrodias: I now realize that I completely missed your earlier post, sorry for that!
    As to the backup logic, when using "only if newer" it actually compares the "last modified" timestamp of the backup file and the workshop json. I'll have a look at that and see if I can optimize that. What exactly takes long, checking if backups need to be made, or the actual backup process? I use 7zip in the background to create the backup's, I'm not sure if I can speed the actual backup process up.
    I'll have a look at the cleanup function, I thought I changed everything related to the "chest->saved objects" change, seems like I missed something.

    @MIC132: I'll have a look how thumbnails get loaded, what the filenames of the workshop files have to do with the thumbnails etc.

  6. #231
    Now I must apologize. Paying closer attention and trying individual mods, it seems I may have been mistaken about it being inordinately slow. The time it takes legitimately seems to be simply the amount of time to compress and transfer across the network, which isn't a quick process. There isn't any obvious time-wasting going on.

  7. #232
    Ok, so it seems thumbnails get only loaded if the mod filenames consist of only numbers (workshop id). as soon as there is anything else in there a thumbnail will not get loaded. As the thumbnails get downloaded from steam ,i.e. they are only available for workshop mods anyways, that actually makes sense. Of course this prevents mods from other sources with json filenames other than a workshop id from getting loaded even if they would be present.

  8. #233
    Nice job keeping up with the updates!

    I have a suggestion: Create the backups (and maybe do other things) with a worker thread that's separate from the UI. As it is, the UI kind of locks up while it's making backups. It's okay to disable the buttons in the UI thread before queuing the job.

  9. #234
    Quote Originally Posted by Corrodias View Post
    I have a suggestion: Create the backups (and maybe do other things) with a worker thread that's separate from the UI. As it is, the UI kind of locks up while it's making backups. It's okay to disable the buttons in the UI thread before queuing the job.
    You are right, thats one place where I forgot to do that, I'll add that in the next update. I tried to change everything that takes "longer" to use threads to not lock up the UI but I might have forgotten other places too, so if you notice any more things that lock the ui let me know

  10. #235
    I will download and will try it out this weekend. Thanks for it.

  11. #236
    Can you please look into this error (in italian) that i get trying to download a workshop id:

    Impossibile caricare il tipo 'Json' dall'assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.

    I get a similar error (as a popup) if I put myself a .json file into the mod folder and "refresh" (but with a .cjc works fine).

    PS: I'm using the last version of TTS backup tool (1.9.1)
    Last edited by giudark; 03-15-2017 at 10:21 PM. Reason: add post scriptum

  12. #237
    Quote Originally Posted by giudark View Post
    ...
    You may need to update or repair your .NET Framework. Otherwise, maybe it doesn't know where your TTS is installed, but I don't know how to change that.

  13. #238
    Deleting mods does not seem work. The program just hangs after pressing yes on "Are you sure" prompt.

Page 10 of 10 FirstFirst ... 8910

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •