Page 13 of 13 FirstFirst ... 3111213
Results 301 to 319 of 319

Thread: TTS Mod Backup tool

  1. #301
    Workshop downloader saves mods as "game name" ("ID").json while the thumbnail downloader saves images as "ID".png. This results in thumbnails not working in the game.

  2. #302
    Join Date
    Sep 2015
    Posts
    150
    Oops, will fix in next version, thanks for reporting!

  3. #303
    Having this crash everytime I load ... just started.. may have something to do with the patch.. it seems to be something to do with the MOD JASON files... as if I delete them all, then it loads fine and works off the save games no problem..

    The crash report will not send.. so putting it here...

    Could not load type 'SimpleJSON.JSON' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'. - 1.9.20.0
    System.TypeLoadException
    Could not load type 'SimpleJSON.JSON' from assembly 'Assembly-CSharp, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.
    \n at TTS_Mod_Backup.WorkshopManager.CheckWorkshopItemsE xist()
    at System.Threading.ExecutionContext.RunInternal(Exec utionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionCon text executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    at System.Threading.QueueUserWorkItemCallback.System. Threading.IThreadPoolWorkItem.ExecuteWorkItem()
    at System.Threading.ThreadPoolWorkQueue.Dispatch()
    My Boardgame uTube chan - Tragic's Table Top
    BGG Guild of BoardGame uTubers - Tube Tables

  4. #304
    I'm getting the same issue as Tragic above. No idea if it is patch-related as I only just downloaded your app.

  5. #305
    Same issue crashing, it was working fine before the new Update to TTS

  6. #306
    Join Date
    Sep 2015
    Posts
    150
    Yes, thanks for reporting, this was caused by some internal changes in the latest TTS update, I just uploaded a new Version that works again

  7. #307
    great stuff FrogHut... TTSBackup is an invaluable tool.. I use it all the time. Thanks!
    My Boardgame uTube chan - Tragic's Table Top
    BGG Guild of BoardGame uTubers - Tube Tables

  8. #308
    hello there. first of all, i love that tool its so handy and useful.
    but there is an really annoying bug. at first it sounds like a small bug but in fact, its totally annoying.
    its about displaying mod names in tts mod backup.
    there are some mod names like ... lets say "pokémon" or german names with special characters like "ä, ü, ö" for example. or general special characters... % $&!§")/%(("&/ ... stuff like that.
    they are not displayed properly. or if a mod has a russian name.. russian letters... or idk, arabic, chinese, japanese.. whatever different letter types exist...
    sometimes tts mod back up displays the names right, but many times, if there are special letters "for example "ä" " it shows a "?" or a "@" instead of that letter/character.
    and then... if i click "back up all mods" (because i dont always remember which one i already backed up), i decline to overwrite already existing backups. but when the names are always displayed differently, due to special letters/characters, tts mod backup thinks that its a new mod now and will back it up again.
    i had a mod with "pokémon" for example, it displayed the name correctly when i added it the first time. then i added more mods and clicked "backup all" and then i see, that i have another "Pok?mon" mod backed up. it was exactly the same, but with an "?" instead of an "é".
    idk these special letters/characters arent displayed correctly. my windows display em correctly. but in tts mod backup its not displayed correctly.

  9. #309
    hi there. something strange happened again. this mod got an update today in TTS Workshop: https://steamcommunity.com/sharedfil...?id=1254097139
    i made tts mod backup look for updates and it said the mentioned one had an update. but the loading bar stopped halfway. so i deleted the mod and copied&pasted the mod ID into tts mod backup to redownload it.
    but it gave me Remoteserver-Error (504) all the time. some hours are over now and still same error.
    then i jsut subscribed that mod in steam workshop and it got downloaded without problems. and tts mod back up recognized the subscribed mod, too. and logically, there was no update anymore for that mod when
    i looked for updates in tts mod backup again, because the steam workshop subscription for that mod already downloaded the newest updates.

    so what i understand from that case.. there are probably some special settings you can make in the json file, so tts mod backup will have problems to get the updated json file of a mod.
    Last edited by ttsbalance; 07-31-2018 at 08:42 AM.

  10. #310
    Join Date
    Sep 2015
    Posts
    150
    @ttsbalance: I'll take a look at both your issues, thanks for bringing them up!

  11. #311
    Hey Frog.. it would be awesome if there was a way to select a mod and "delete all local content"... maybe I could ask for that as a feature? or be told how to do it if it exists.
    My Boardgame uTube chan - Tragic's Table Top
    BGG Guild of BoardGame uTubers - Tube Tables

  12. #312
    Quote Originally Posted by Tragic View Post
    Hey Frog.. it would be awesome if there was a way to select a mod and "delete all local content"... maybe I could ask for that as a feature? or be told how to do it if it exists.
    Wait - is this not what right clicking and 'Delete local files' does?

  13. #313
    hi there. some other issues came up.
    1. when clicking "backup" a game, but you decide to cancle it (in the very first window, where you can select destination folder), then TTS mod backup freezes and everyhthing greyes out.
    2. the current version on nexusmods is still 1.9.22 but when downloading it, tts modbackup auto updates to 1.9.23
    3. is it possible to build in a "cancle" button when downloading a mod? because tts mod abckup is completely greyed out when downloading a mod. and sometimes the mod is very bid and you decide to download other smaller mods first,
    then you want to continue the big mods. but yeah, to "pause/cancle", currently you need to hard-close (clicking "x" to close the tts mod backup software completely) to stop the downloading. and that can be annoying.
    4. is it possible also to build in a "copy all locale filenames" ? i know there is an opion for "copy all missing urls" but many times, instead of urls, all of the locale file names are needed to provide a list for modders, so they can search
    for the missing files in their own tts locale folders.

    and yeah, just to sum it up here.. the 2 other bug reports i made some time ago. im just including them here so you can have a better overview:
    5. special characters are not displayed correctly. for example ä, ö, ü, /, é (etc...). they look like this "Pok?mon". this can be problematic when backing up mods. because the name changes somtimes into "Pok@mon". when i started tts mod backup the first time, it was displaying it correctly. so... that resulted in me having 3 different backups of the same mod (cause i often use "backup all mods"). so i had at the end: 1. Pokémon 2. Pok?emon and 3. Pok@mon (just an example what i want to try to say).
    6. some workshop mods give errors when trying to "update mods". i dont know why. they didnt give errors at the beginning. but on later updates of the mods, i get the errors. so i need to subscribe them in the worksho to prevent thesee errors. maybe the jsons are not downlaodable anymore for tts mod backup because of big changes? for example, for this mod, an error occurs when "updating mods" and if you dont have it subscribed in steam (of course it requires the mod to have an update first): https://steamcommunity.com/sharedfil...?id=1254097139
    Last edited by ttsbalance; 08-07-2018 at 04:55 PM.

  14. #314
    Can you add a "stop downloading" button?
    sometimes while downloading all, the download gets stuck and I have to close and reopen the program and wait for it to check the mods all over again
    i guess a STOP button will fix that for me

  15. #315
    Great tool concept, wonderful implementation. I am impressed how well you support this utility.

    I have a questions regarding backups of saved items.

    When the "Saves Tab" is selected and you select a save item in the list of saves, and then you right click on that saved item, a menu is displayed and one of the choices is "Backup". If you select "Backup", the selected save item is not backed up; however, if there was a mod previously selected under the Mods tab, that mod is backed up instead of the selected save item.

    Is this behavior per design? Should we not be able to backup saved items only mods?

    Thanks, keep up the great work!!

  16. #316
    normally you need to convert saves into mods to back them up. i think the option "backup" in the right-click context menu for "Saves" should better be greyed out. maybe the developer just forgot to remove it. if you ask me, thats a tabletop-simulator thingy that it probably makes it impossible to backup Save Files. thats why you need to convert them into Mods before you can (just an idea why it isnt working with "Saves")

  17. #317
    There is a bug when say you click the Backup to backup mods but decide not to and hit Cancel it locks up the program where you can't do anything without Restarting

    --Edit-- 9-22-2018 I am also now getting a Crash allot with this error The remote server returned an error: (429) Too Many Requests.
    Last edited by Sorcerer; 09-22-2018 at 03:43 PM.

  18. #318
    Allways the same error...every time I opne the software:

    100.jpg

    101.jpg

    102.jpg

    103.jpg

    I deleted all the files and started from zero. And without files in the folders the error still comes out.
    Always the same error.

    Please, any help?

    Thank you.

  19. #319
    @darlethman use the built in Updater its under Help then Check for Update

    The latest version is 1.9.23 and I think the only way to get it is through the built in updater

Page 13 of 13 FirstFirst ... 3111213

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •