Page 14 of 15 FirstFirst ... 412131415 LastLast
Results 326 to 350 of 375

Thread: TTS Mod Backup tool

  1. #326
    I know TTS Mod Backup is not hacking Steam and that it uses the Public Steam API. Just was saying it could cause problems with the crappy way Steam checks VAC games. Its not a problem with TTS MB but Steam and the way they check VAC games.

    The Steam VAC is crap and there is always a possibility that it could cause problems, I myself make sure nothing else is running that could mess with the Steam VAC but it could happen.

    As for the other the crashing is fixed.

  2. #327
    Quote Originally Posted by Sorcerer View Post
    Just was saying it could cause problems with the crappy way Steam checks VAC games. Its not a problem with TTS MB but Steam and the way they check VAC games.

    The Steam VAC is crap and there is always a possibility that it could cause problems, I myself make sure nothing else is running that could mess with the Steam VAC but it could happen.
    No, that is not the way VAC works. It's checks for programs that are editing active memory and affecting multiplayer games, not programs using their public API for downloading mods. TTS Mod Backup is nowhere near the first workshop mod program that hooks into Steam. Please stop pretending you know what you are talking about.

  3. #328

  4. #329
    The developer pays close attention to reports, so make sure you send it.

  5. #330
    using this tool logs me out of the steam client because iam logged in somewhere else.

  6. #331
    When I open TTS Mod Backup with Steam running, I see the GUI for a second then it crashes, no crash report. When steam isn't running then it starts but crashes when I try to update installed mods from workshop. When I try to download a mod from workshop by ID i get this error in the console but it doesn't crash: "Error downloading Workshop Mod: An exception occurred during a WebClient request." Any Ideas?

  7. #332
    I have a similar experience to gommb. It just crashes and does nothing.

  8. #333
    hi there.
    please can we get back the seperate button for "download thumbnails" ? downloading thumbnails is bugged. its not downloading thumbnails unless any of your downloaded mods has a real update. if the updater finds an update for a mod, THEN it looks for still missing thumbnails. so in other words, if you have everything up to date, but add a new mod via mod ID, then you can download that mod but thumbnail will not be downloaded. it will only be downloaded next time when any mod has an update. i tested it, i clicked "update mods" many times but no thumbnail downloads when there was no other mod with an update available.
    it only looked for thumbnails when at least one of your existing mods had an update.

  9. #334
    ok dumb question.. how do I install this program? and theres no instructions. please help. ty

  10. #335
    Join Date
    Mar 2019
    Location
    USA
    Posts
    3
    Hey Froghut, thanks for the great backup tool. I am not sure if you are still active on this forum but I wanted to bring to your attention that my version of TTS Mod Backup no longer auto-populates it's mod list.

    I can still download mods via the workshop ID, and they are then added to the list afterwards but I cannot get the list to populate otherwise. This was happening on version 2.0.7, thought it may have been a bug so I updated to 2.0.9 and the problem persists so I am unsure whether or not TTS itself is the cause of the issue.

  11. #336
    latest tool version (2.0.9) not working anymore for newest TTS 11.2 update. just wanted to inform.

  12. #337
    thanks for the update, it is working now again with tool version 2.0.10. but there is a heavy bug. 90% of all my mods i have are now all marked red, as if i dont have the data for them.
    to be detailed, the its the image data which are not recognized anymore.

    lets say i already have the file "xyzcomjpg.jpg"
    but tts modbackup tool says: download it, you dont have it. - when i download it and check the file, i can find the following downloaded file: "xyzcomjpg"
    so as you can see, the file extension is missing. so i assume thats why the tool v2.0.10 thinks i dont own the majority of files, because it isnt looking for jpg or png files, but only for the names without the file extension.
    i dont know if there are any more file extensions not being recognized by the tool. but as for now - and as far as i can tell - only image file extensions seem to be affected by this bug (jpg, png ... etc.)
    Last edited by ttsbalance; 04-05-2019 at 03:44 AM.

  13. #338
    Hi im stuck on the 11.2 version on the game for some reason but when i try to use the tool i get this error "Method not found: 'System.String TextureScript.ConvertURL(System.String)'." the stacl trace is "\n at TTS_Mod_Backup.ModManager.<>c__DisplayClass67_0.<G etModsFromJson>b__1(String file)
    at System.Threading.Tasks.Parallel.<>c__DisplayClass1 7_0`1.<ForWorker>b__1()
    at System.Threading.Tasks.Task.InnerInvokeWithArg(Tas k childTask)
    at System.Threading.Tasks.Task.<>c__DisplayClass176_0 .<ExecuteSelfReplicating>b__0(Object )"

  14. #339

    I have 3 big issues with version 2.0.10

    Ok i tried the new version 2.0.10 because of the error flood on startup on versions below 2.
    There are 3 big issues i noticed.

    1.
    I cant update the program from below version 2 too many errors. So i downloaded but,
    the file i download from the nexus is detected as virus in chrome. I have to use Firefox to download.
    I can not unzip the exe via drag and drop windows defender is blocking.
    So i created an exclusion for the app folder in windows defender and then unzipped via rightclick menu "unzip here".
    Tested without the exclusion rule in windows defender and it wont let me start the app anymore.

    2.
    Okay so i start it up and all my mods are listet as red(not downloaded).
    I made tests and checked the images folder. All files downloaded with the backup software have no suffix. (.jpg is missing) If i download the files via tabletopsim they have the suffix. So this is a bug.
    If i download only via backup software and start the mod ingame it does not use the files without suffix it downloads the files again as normal.

    3.
    If i have the backup software running before i start the game it wont let me start it. I guess its somehow emulates the game to be able to download from the steamplatform. This could also be the problem it is detected as Virus.

    And maybe also the reason for this. But this is a wild speculation.

    Quote Originally Posted by Seppel View Post
    using this tool logs me out of the steam client because iam logged in somewhere else.
    Btw it is detected as Trojan:Win32/Azden.A!cl
    I guess it is a false positive.

    What is your experience guys?
    Last edited by Faro; 04-06-2019 at 04:47 PM.

  15. #340
    Quote Originally Posted by Faro View Post
    What is your experience guys?
    I'm experiencing the same issues as you describe. The extension is the big one since there's no point in downloading the mod if TTS will have to download everything again while loading.

    Same trojan detected here. I assume it is a false positive.

  16. #341

    Same

    It doubled the files i have on my system...so that's a big problem, and yeah, my AV went crazy reported it. I went to the website and the file can't be downloaded (at least for me) so maybe an update is coming. (I also noted that the site itself marked it as having suspicious files, so that could be part of the issue downloading?)

    Thanks
    -Gregory

  17. #342
    same experience and the following linked post of mine explains why this occurs (to have a tip what to fix)
    http://www.berserk-games.com/forums/...3868#post23868

  18. #343
    Does anyone have a copy of 2.0.9 available still? (I was able to get it working satisfactorily by using a previous version of the Assembly-CSharp.dll file from TTS.) This regression bug of not recognizing the image extensions is just too much of a headache to deal with.

  19. #344
    btw, the bug aside, tts modbackup got deleted on nexusmods because of being a suspicious file.

  20. #345
    Quote Originally Posted by TRIBALien View Post
    Does anyone have a copy of 2.0.9 available still? (I was able to get it working satisfactorily by using a previous version of the Assembly-CSharp.dll file from TTS.) This regression bug of not recognizing the image extensions is just too much of a headache to deal with.
    I do I always archive up the last version I had before I update just incase so I have a copy of 2.0.9

    Not sure what the rules on posting file links is here so I PMed you with the Link

    -- Edit --

    From what I have found the Extension bug seems to only be for Images and not Models or Assetbundles just thought I would let the Dev Know that.
    Last edited by Sorcerer; 04-12-2019 at 10:52 AM.

  21. #346

    can you share 2.0.9

    Quote Originally Posted by Sorcerer View Post
    I do I always archive up the last version I had before I update just incase so I have a copy of 2.0.9
    The latest one I have is 2.0.7 can you share the file?

  22. #347
    Quote Originally Posted by kamesenin888 View Post
    The latest one I have is 2.0.7 can you share the file?
    I just PMed 2.0.9 to you

    You will need to see if TRIBALien will send you the version of Assembly-CSharp.dll he has I do not have that

  23. #348
    Does anyone know what the status of Froghut's tool is at the moment? I am unable to download it anymore - Nexus simply reports that the mod 'cannot be downloaded yet' - this has been the case for a week or so now.

    Before then was getting nothing but eccentric error messages when attempting to use the app I already had installed.

    Is Froghut still supporting it?

  24. #349
    Quote Originally Posted by Sorcerer View Post
    I just PMed 2.0.9 to you

    You will need to see if TRIBALien will send you the version of Assembly-CSharp.dll he has I do not have that
    Thank you for the file Sorcerer. From what I could gather, TTS Mod Backup previously relied upon a file (Assembly-CSharp.dll) located in the TTS installation for the JSON parsing. When TTS was last updated, that file was changed as well which resulted in TTS Mod Backup throwing up errors whenever it was run.

    I temporarily reinstalled TTS to the last version via Steam to grab that file. (A 5GB download to obtain a 5 MB file...Ugghhh!) If Assembly-CSharp.dll is placed in the same directory as TTS Mod Backup version 2.0.9, then it will use that version of the DLL before trying to use the new version used by TTS.

    The backup files may be found here (Google Drive) or here (Sendspace).

    P.S.
    The presence of Assembly-CSharp.dll in the same directory will cause newer versions of TTS Mod Backup to be unusable as well. So when Froghut releases a new version, you'll need to delete or rename Assembly-CSharp.dll before running.

    [Edit]
    Sorry, the Sendspace archive didn't contain the necessary DLL. I've updated the link.
    Last edited by TRIBALien; 04-14-2019 at 09:37 PM. Reason: updated download link

  25. #350

    thank you so much

    Quote Originally Posted by TRIBALien View Post
    Thank you for the file Sorcerer. From what I could gather, TTS Mod Backup previously relied upon a file (Assembly-CSharp.dll) located in the TTS installation for the JSON parsing. When TTS was last updated, that file was changed as well which resulted in TTS Mod Backup throwing up errors whenever it was run.

    I temporarily reinstalled TTS to the last version via Steam to grab that file. (A 5GB download to obtain a 5 MB file...Ugghhh!) If Assembly-CSharp.dll is placed in the same directory as TTS Mod Backup version 2.0.9, then it will use that version of the DLL before trying to use the new version used by TTS.

    The backup files may be found here (Google Drive) or here (Sendspace).

    P.S.
    The presence of Assembly-CSharp.dll in the same directory will cause newer versions of TTS Mod Backup to be unusable as well. So when Froghut releases a new version, you'll need to delete or rename Assembly-CSharp.dll before running.
    thanks man )))

Page 14 of 15 FirstFirst ... 412131415 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •