Page 15 of 15 FirstFirst ... 5131415
Results 351 to 375 of 375

Thread: TTS Mod Backup tool

  1. #351
    unfortunately since i updated kaspersky today, it deletes all tts modbackup tool versions and says its a virus. doesnt matter if its 2.0.10 or 2.0.9. before the kaspersky update it never did that. this is so annoying..
    so just in case if you (froghut) plan on continuing this tool, recently antivirus software give alarm and auto-delete them (at least kaspersky does since todays update)

  2. #352
    Hey awesome,

    thanks TRIBALien and Sorcerer.

    This works for now!

    And for the antivirus problem you maybe can create some exclusion rule inside the program?
    I only use windows defender. So i dont know.

  3. #353
    well i trusted the tool because until today there was never an alert by kaspersky. but thats probably because i used the tool since a long time and the inbuilt updater always updated the tool. so kasperky probably still said "the tool is safe". i made a new viruscheck and its a bit heavy when 17 of 71 antivir software say its not safe. fun thing is, almost all alerts say the same results, that it is a spying trojan.

    i really love this tool but i think the developer really should use codes and stuff which dont get us lots of alerts (not sure if they are false or real alerts currently) or if he needs to use codes which give false alerts, then he maybe should make the code for tts backup tool open souce so we can be reassured by seeing it is safe to use.

    ... i mean even nexusmods recently took out the tts modbackup file. you cant download it anymore.

    just my opinion.
    Last edited by ttsbalance; 04-15-2019 at 09:54 AM.

  4. #354
    This tool has been removed from Nexus... due to the virus issue... no idea if it is still in development or what.... but this is an absolute MUST tool for TTS... I hope it gets fixed at some point. Really the devs themselves should be providing a tool like this imo.
    My Boardgame uTube chan - Tragic's Table Top
    BGG Guild of BoardGame uTubers - Tube Tables

  5. #355
    So there appears to be a new version of the backup tool up on Nexus. I dl'd it and tried it, and it seems to be working, though there was one crash.

    It's backing up files, anyway.

  6. #356
    thanks for the update

    EDIT: unfortunately my antivir still alerts me and says its a trojan and starts to desinfect it.
    well this time only 2 antivir alert on virustotal, and kaspersky is still included. ive got the feeling it is a false alert, but v2.0.9 still has 20+ alerts. sorry for bugging you about this here again, since i already left you a private message, but it would be really reassuring for me and probably for others, too, if you (froghut) could give us your opinion regarding these antivir alerts for v2.0.9 and v2.0.12. like.. if you know what causes it, just saying for example.. "its false alert, because some code isnt liked by antivir, i checked it" would be enough to set us at ease. - otherwise: great work with tts modbackup. its a great and useful tool for TTS.
    thanks in advance!
    Last edited by ttsbalance; 04-21-2019 at 09:20 AM.

  7. #357
    Hmm. Neither Defender nor Malwarebytes seems perturbed by it.

  8. #358
    in the meantime tts mod back version 2.0.9 and 2.0.12 and 2.0.13 was sent by me and a friend to kaspersky as a false alert so they could check the files manually. they confirmed it was a false alert and they fixed the false alert for the named three versions. but i dont know if another false alert can happen when a new update of the tool is released.

    so it looks like there is some code inside the tool that behaves the way some antivir software dont like. but the tool is up to the current date safe to use.

  9. #359
    Join Date
    Mar 2019
    Quote Originally Posted by TRIBALien View Post
    Thank you for the file Sorcerer. From what I could gather, TTS Mod Backup previously relied upon a file (Assembly-CSharp.dll) located in the TTS installation for the JSON parsing. When TTS was last updated, that file was changed as well which resulted in TTS Mod Backup throwing up errors whenever it was run.

    I temporarily reinstalled TTS to the last version via Steam to grab that file. (A 5GB download to obtain a 5 MB file...Ugghhh!) If Assembly-CSharp.dll is placed in the same directory as TTS Mod Backup version 2.0.9, then it will use that version of the DLL before trying to use the new version used by TTS.

    The backup files may be found here (Google Drive) or here (Sendspace).

    The presence of Assembly-CSharp.dll in the same directory will cause newer versions of TTS Mod Backup to be unusable as well. So when Froghut releases a new version, you'll need to delete or rename Assembly-CSharp.dll before running.

    Sorry, the Sendspace archive didn't contain the necessary DLL. I've updated the link.
    Hey TRIBALien thanks for your help. I saw that you updated the sendspace link to include the necessary DLL, however I just downloaded it and the DLL was not present in the zip. The google drive link has also been removed due to a service violation.

  10. #360
    I just checked the archive at the Sendspace link and it does include the DLL. Since TTS Mod Backup has been updated, however, you would probably be best using the current version (2.0.15) and not having to bother with this link.

  11. #361
    Join Date
    Mar 2019
    Thanks for the quick reply. Unfortunately the most recent version 2.0.15 is still giving me the "infinite error popup" problem which is why I was looking at going back to a previous version. I downloaded the sendspace file again and this time the DLL was present, so I am unsure how it failed the first time but it all seems to be working for me now.

  12. #362
    Feedback: You are the savior of many hours of my life that would have been spent organizing, downloading, verifying, coding. Thank you!

    Bug report(ish?):
    That mod has both and listed as URLs for separate meshes. The 1st downloads, the 2nd does not. I verified manually that it is a .obj that loads correctly. I looked and 'raw.php?i=' just forwards to 'raw/'. I'm not sure what the normal convention is for naming when it comes to those URLs and TTS as I'm new, so I'm not sure if it actually is a bug, or something they should have fixed in the mod .JSON so I'm just leaving this here fyi in case you want to wanted to add the ability to handle both URL conventions.


    1. When there are files missing from a download, a pop-up identifies that there are missing files, and it asks you to verify if you would like to continue with the backup. This pops up when it starts that specific mod's backup. This prevents doing batches of backups of which some might include a missing item or two that isn't important to the mod's functions to take place unattended. I suggest that you have all pop-ups for all mods with missing items in a batch job to be presented to the user at the beginning of batch creation, perhaps with a yes to all/no to all available. This will allow unattended function for backup.

    2. Under contained URLs it might be beneficial to be able to contract/expand the sub-categories of items (tables, deck, etc...) so that you can see what items are present for specific sub-categories.

    4. Add a tooltip for the Do it All button. I still don't know what it does as a new user of your program. I was afraid to push the button to find out, but when I did I couldn't tell what if anything it did.

    5. A stop/abort/cancel button. A lot of the functions the program performs have long wait times. if you mis-click or realize you don't need to do something your current options are to wait or close the program.

    6. a backup & export to exe button that will send the 'backup' function output to the 'export to exe' function. Currently I believe you have to back it up and then export, and then delete the ttsmod file.

    7. Currently if I have a tts save I downloaded that I want to backup, my understanding is that I need to manually move the file to the save folder, then refresh in TTSMBU and then convert save to mod and then delete the save from the save folder. Perhaps add a menu option that opens a file management window where a person can just select a save file from any location on the disk to be directly converted to a mod and then add it to mod list without requiring a refresh.

    8. The Filename display in the lower right looks like a text input field. It's confusing, personally. I thought I might be able to paste a file name and it would allow processing of that file from the mod save location at the top.

    Sorry I'm not trying to tear down your UI. I did software/UX/UI QA for many years so I find myself habitually and automatically critiquing any program I personally use. Again thanks for your work.

  13. #363
    Hi Froghut, I'd like the ability to re-upload a mod's assets to Google Drive so that I can host a mod without dealing with distributing backups. Are you interested in collaborating to add this feature to TTS Mod Backup? Is the project open source (I can't find it on GitHub)?

  14. #364
    The old bug in TTS that screws up the display is back for some reason.. I think it is when windows 10 scales for 4K monitors.

    I hope there is a way to fix this....
    My Boardgame uTube chan - Tragic's Table Top
    BGG Guild of BoardGame uTubers - Tube Tables

  15. #365
    For some reason i can't get 2.0.17. Start the app (2.0.15) and it see there is an update. It creates a backup folder and copies it in there and then stops. I turned off my AV and tried running it as admin.

    Any one have any suggestions? Or just send me the .exe?


  16. #366
    I downloaded the old copy from nexusmods and ran that version. When it updates to the current version with that method, I get a Windows popup telling me that it is potentially an unsafe program. After I choose to run it anyway, I don't seem to have any issues.

    This leads me to believe that Windows' UAC settings are what stop the program from updating normally.

  17. #367
    I have been receiving this error when trying to backup my TTS mods for the past several versions. I honestly have no idea what to do at this point and would really like some advice. I have a couple hundred mods right now and had successfully done backups in the past, but after the end of last year, it's been nothing but this error when the list refreshes. I have been also submitting those error reports for each version.
    Attached Images Attached Images

  18. #368
    That worked Thank you! I'm now current!

  19. #369
    I have a question about TTS Mod Backup Tool: What is the difference between the "download" and "backup" function?

    I just want to make sure I haven't been making a mistake in my attempts to protect my mod collection. I have just been doing "Backup All" to a secondary hard drive. Does this actually make a copy of all the assets in case the links get taken down? Or do I actually need to separately "Download All" as well. And if I do, then what is "Backup" doing? Thank you for any explanations.

  20. #370
    The download button pull all the assets local, and the backup function puts all the assets into a single file that can be restored if the original becomes lost/deleted or etc. (also tradable to others that use TTS Mod backup if the mod is removed from Steam.)

    Hope that helps

  21. #371
    Quote Originally Posted by Tragic View Post
    The old bug in TTS that screws up the display is back for some reason.. I think it is when windows 10 scales for 4K monitors.

    I hope there is a way to fix this....

    Finally found a solution for this.... right click on the exe, select properties and go into COMPATIBILITY.. then click CHANGE HIGH DPI SETTINGS and tick OVERRIDE HIGH DPI SCALING.... and then set it to SYSTEM.
    My Boardgame uTube chan - Tragic's Table Top
    BGG Guild of BoardGame uTubers - Tube Tables

  22. #372
    Anyone else have problem where it doesn't download thumbnails/icons?
    It's supposed to do it after "Update mods from workshop" and it did work some time ago but it doesn't seem to work currently.

  23. #373
    Quote Originally Posted by MIC132 View Post
    Anyone else have problem where it doesn't download thumbnails/icons?
    It's supposed to do it after "Update mods from workshop" and it did work some time ago but it doesn't seem to work currently.
    yeah this was mentioned before. i know TTSMB is free and stuff, but sometimes i wonder if the dev of ttsmb is reading posts here, since there are really old bugs which were never fixed (for example the name-screwing-up bug when the mod title has special letters like or etc.. or when the title-name is in a different letter-language like chinese, japanese, russian etc.). or when you backup saves from TTS, and re-add them, they are added as mods and not as saves again.

    unless there are any real updates for your mods, ttsmb wont look for thumbnails. only if it finds mod update, AFTER that it will immediately look for thumbnail updates. i liked the previous versions better where the thumnbail update button was seperately. that way you could always make it look for thumbnails.

    if it is possible, i would love to see a QoL update (Quality of Life) that fixes these bugs. they are bearable.. but time consuming and kinda annyong.

    - and btw. since the new tts update, mp3 and pdf support was added. but ttsmb is ignring mp3 and pdf files, not listing them in the download section. so basically you wont get any errors but at the same time you will download mods with missing files if they had any mp3 or pdf.
    Last edited by ttsbalance; 08-18-2019 at 06:53 AM.

  24. #374
    So I have gone through the process to set this all up, however in TTS All my assets are still pulling from the dropboxes/imgur links etc. I have used the do it all and extracted the the mods into the mod folder. My worry is that I am going to have to individually choose the file path for each individual asset. I am uncertain what I am doing wrong and would love some assistance. Ultimately I just want to use my own uploaded or local files for these assets as it seems everytime i save the game the webhosted images lose their link so I can never actually prepare a map.

  25. #375
    I tried to run this tonight and Windows virus protection quarantined it. I tried redownloading and running it again and got the same result. This worked fine last week.

    I can tell it to let it run but the app crashes either way.


Page 15 of 15 FirstFirst ... 5131415

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts