Page 4 of 15 FirstFirst ... 2345614 ... LastLast
Results 76 to 100 of 374

Thread: TTS Mod Backup tool

  1. #76
    Join Date
    Sep 2015
    Posts
    150
    I checked the file from Nexusmods in Virustotal and one of 55 scanners detect something, but I can assure you it's a false positive. The tool uses a few dll's and I package them into the .exe (to make it more portable) and I guess thats why some scanners think there's something fishy in it, but it really is not

  2. #77
    I saw the program has been updated, that's awesome

    I have a question though, did you ever implement the feature that removes 'Do not download' from files that have been updated/modified?

  3. #78
    Still having 'Could not create SSL/TLS secure channel.' with Dropbox after the update.

    Also, I wanna sneak in a small feature request, could there be a feature to open JSON files with Notepad or something instead of the built in editor? Generally when I check for a broken asset, I need to open it up search for that URL and see what it's tied to - and sometimes it's something that's fallen underneath the world.

  4. #79
    Join Date
    Sep 2015
    Posts
    150
    - I totally forgot about the do not download removed after update, I'll add it to the todo list.
    - I though I had fixed the dropbox SSL problem, I'll check it again.
    - I'll also add the "open external" feature for json editing.

  5. #80
    "I though I had fixed the dropbox SSL problem, I'll check it again."

    Problem is it only happens sometimes. Generally in a 100 asset file I'll get 10 downloads from dropbox that failed.

  6. #81
    Join Date
    Sep 2015
    Posts
    150
    Quote Originally Posted by Froghut View Post
    - I totally forgot about the do not download removed after update, I'll add it to the todo list.
    - I though I had fixed the dropbox SSL problem, I'll check it again.
    - I'll also add the "open external" feature for json editing.
    I uploaded 1.8.7 with those features included, although I'm not 100% sure if I fixed the dropbox problem...

  7. #82
    NUpdateApp keeps crashing this time around. Normally autoupdate works fine.

  8. #83
    Quote Originally Posted by Froghut View Post
    I uploaded 1.8.7 with those features included, although I'm not 100% sure if I fixed the dropbox problem...
    A bit more reliable, but not fixed. A 3 asset mod using entirely dropbox links had 1 of em fail due to an SSL error.

    Maybe have it keep looping retries with this sort of error for at least 5 seconds?

  9. #84
    Join Date
    Sep 2015
    Posts
    150
    regarding the updater crashing, I made a dumb mistake and now it's broken for 1.8.6 :/ You'll have to manually download 1.8.7 again from nexusmod or from http://abomb.info/tts/dl.php?file=TT...ckup_1.8.7.zip which now contains a fixed updater again.
    for the dropbox problem, yeah I'll add something like that, thanks for reporting again!

  10. #85
    I think the Create Selfextracting Backup button got broken at some point. I clicked on it and tried to create a file, but for some reason it wants me to OPEN a file rather than SAVE a file...

  11. #86
    Join Date
    Sep 2015
    Posts
    150
    It's actually just wrong text in the open file dialog, I'll fix the text in the next version, thanks for spotting that!
    But even with the wrong text the function as such still works, you select the .ttsmod files you want to create SFX backups from, once you open them it will create .exe files for the selected files.

  12. #87
    A couple of very minor points :

    There's a typo in the report of haveing converted a save to a mod - it reads "Successfully vonverted..." .

    And if you try to use an invalid character in the name of a file (e.g. a colon) when asked for the name you want for a save-converted-to-a-mod, instead of reporting what the problem is it brings up an "Unhandled exception has occurred" error.

  13. #88
    Join Date
    Sep 2015
    Posts
    150
    Added to ToDo list, thanks for reporting!

  14. #89
    The pastebin issue is still happening, won't download standard pastebin links.

  15. #90
    Does anyone have problems with 'states' in downloaded mods?
    I tested in Betrayal at the house on the Hill 2nd edition (https://steamcommunity.com/sharedfil.../?id=504889587) and the states that tokens and characters should have aren't there.
    I downloaded the mod using TTS Mod Backup, and I'm wondering if the downloading method is at fault, since someone on steam confirmed it works ok for them.

  16. #91
    Join Date
    Sep 2015
    Posts
    150
    I can't imagine that the download method is at fault, but I will check it out, weirder things have happened

  17. #92
    Well, I also doubt it, but I'm kinda out of options.
    Perhaps simply check the mod I linked? Download it using TTS Mod Backup and check if the character cards and tokens (near counter) have states? If they don't do same through workshop. Then we'll know something.

  18. #93
    It appears there might be some problems.
    I just got a backup from the author of the Red Dragon Inn (I had some problems with that mod, not involving states, but a token that was supposed to have two different sides was the same on both sides), and his .json differs from my .json of the mod. Despite mine being latest updated version (using TTS Mod Backup).
    The difference is here (It starts on line 7654, if you wanted to check that mod by yourself):
    Code:
    "CustomImage": {
                "ImageURL": "http://i1381.photobucket.com/albums/ah214/SnufferinSnagglepuss/IMG_0039_zpsb9pir7lm.jpg",
                "ImageSecondaryURL": "http://i1381.photobucket.com/albums/ah214/SnufferinSnagglepuss/IMG_0040_zpsl8hnsamw.jpg",
                "WidthScale": 0.0,
                "CustomTile": {
                  "Type": 0,
                  "Thickness": 0.1,
                  "Stackable": false
                }
    My .json (downloaded throug TTS Mod Backup) is missing everything bar the first "ImageURL" and "WidthScale". The whole "CustomTile" part is missing, messing up the token, as well as "ImageSecondaryURL" is missing, so the token is actually same on both sides, while it should be different.

    The file is from the author, so it's possible that the problem is with upload, not download, but I think it's worth checking.

    This probably isn't related to the states problem, at least not directly, but if there is any problem, there might be more. I'll try to obtain a .json of Betrayal from someone it's working for, and compare it with mine.

    EDIT: The "ImageSecondaryURL" is missing in few more places, but there the original was empty anyway.

    EDIT2: So, I got the Betrayal file from someone who got it from workshop and compared. Whole "states" sections of the .json are missing.
    This basically proves that TTSMB is the culprit.
    I'm attaching both .jsons in the zip so you can compare them for yourself. I hope that whatever is causing the problem can be fixed quickly.

    If I might add, if/when you fix it, it would be good to have the program redownload latest versions of all mods that can be redownloaded, to fix all potentially affected mods.
    Attached Files Attached Files
    Last edited by MIC132; 02-01-2016 at 03:32 PM.

  19. #94
    Join Date
    Sep 2015
    Posts
    150
    Yes you are totally right. I think I use some files that are still old / wrong versions, thats why all the "new stuff" is missing. I'll try to fix it and get an update out as soon as possible.

  20. #95
    I'm quite certain it's not mater of how old the files is/if it's the newest version.

    If you look at those files, there are actual HOLES in it. It's not that sections are missing, they are EMPTY. Filled with empty lines.

    It looks like those sections aren't parsed, or are lost during download in some other way.

    If it was matter of just grabbing the wrong version of the file, there wouldn't be so many empty lines in those places.

    EDIT: Ah, sorry. I misunderstood your post. I thought you said it was downloading older versions of the mods.

    Well, I'm waiting for the fix. Thanks for fast response.

  21. #96
    Join Date
    Sep 2015
    Posts
    150
    Yes, it really was the case that I was using old TTS files that caused the problem. I uploaded 1.8.8 with a fix, also with a new "force" update Workshop mods option so potentially corrupt files can be fixed.
    Thanks MIC132 for your help!

  22. #97
    Can confirm it's working properly. Checked on few mods that had problems.

    May I ask, out of 'professional curiosity' (I'm an IT student), what files from TTS were you using and for what? The problems were quite bizarre, so I'm really interested as to what was causing them in more detail. Are you perhaps using some parsing component from TTS?

  23. #98
    Join Date
    Sep 2015
    Posts
    150
    Yeah I'm actually using the Assembly-CSharp.dll containing the code from TTS and use classes/methods that parse/write the json/mod files. Since the .dll was out of date the classes just did not contain the new functionality.

  24. #99
    I just got 1.8.9.
    Any changelog on that?

    Also related - is there anywhere to see changelogs of new versions?

  25. #100
    Join Date
    Sep 2015
    Posts
    150
    Right now there are no changelogs, I'll try to add it to the next version.
    1.8.9 contains a fix for pastebin.com links since TTS can download them even if they don't link to the "raw text" - now my tool can too

Page 4 of 15 FirstFirst ... 2345614 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •