Results 1 to 3 of 3

Thread: Packet loss[?] and ping not relating to actual latency (recent issue, as of 6.8)

  1. #1

    Packet loss[?] and ping not relating to actual latency (recent issue, as of 6.8)

    Hi. The furthest milestone I can place the following issues at is when I got version 6.8. Before I state my issue, I would like to clear a few things up:

    -The game worked perfectly on all but Australian-hosted servers, with all proxies, never above 300 ping even with the farthest of locations as long as they weren't on Terra Australis.

    -I have a 2 Mb/s down 0.5 Mb/s up connection, which is absolutely abysmal (especially as a host for more than 2-3 people in this game), but is fine for just playing.

    -It isn't hardware lag, as my PC can run Tabletop simultaneously with other games without issues.

    -My connection is 100% fibre optic from my PC to the first router outside the country.

    -In case you wonder, my ping is better with the west coast than the east coast because the west coast connection goes through fibre-laden Jordan, the UAE, India, then China, while my connection to the east coast often goes through copper-infested Italy.

    My issue:

    Prior to 6.8, (not sure if 6.8 is the issue, it's just when the issue started; worth noting I started getting issues with Imgur (that later got cleared up) around this time, too) my usual ping with certain areas was as follows, with current averages placed after a | symbol (note that I'm connecting from Giza, Egypt):

    -Eastern Seaboard (US/Canada): ~130-150. | ~230-250.
    -Western Seaboard (US/Canada): ~110-130. | ~160-220.
    -Midwest (US/Canada): ~200. | ~350-400.
    -Europe (sans Italy): ~30-60. | ~130-160.
    -Italy: ~90. | ~140-180.
    -Middle East: ~5-20. | ~70-90. (note this is via European proxy. When I host, through a port-forwarded connection, it remains as-is around ~5-20)
    -Africa (South Africa, specifically): ~60. | ?
    -Far East Asia: ~100-120. | ~140-160.
    -Australia/New Zealand: 330-350. | 580-620.

    On my end, I've attempted using Google DNS & OpenDNS to no avail, as my ISP's DNS has yielded identical results (I still use OpenDNS, as it has less downtime). The main issue is that as soon as something moves, it skyrockets up to 500-800 regardless of location, save for certain hosts whom I still have the previous rates with, of which most have port-forwarded.

    I believe this may be a CDN issue, as this is clearly packet loss, not latency. It's worth noting that the ping is at previous levels before things begin to move, the new averages are based upon after things move, and become dormant again. VoIP lags or gets skipped entirely while the lag occurs, which amplifies my packet loss argument. For what it's worth, I've done a tracert (trace router) attempt with Google servers from all over the world, and have had 0% packet loss with any of them, with the highest ping being 98 MS with Google.com.au (not much of a surprise).

    My ping remains at previous levels in other games, such as ArmA 2, and my VoIP is flawless regardless of country even while Tabletop Simulator is experiencing packet loss; in fact, I've attempted VoIP over Steam, Skype, and Discord with the hosts of the games I've experienced packet loss in, and the calls remain pristine and crystal clear throughout.

    I'm more than willing to answer any questions necessary to help you solve this problem. For what it's worth, the port forward claims I've put forth make it seem like a proxy issue.

    Thank you in advance.

    Edit to clarify: a lot of the time, the proxies still work. In some cases, they go up to 800-900, but if I reconnect, they go back to normal. This didn't happen before 6.8, once more.
    Last edited by TrippyHippie; 03-14-2016 at 12:56 PM. Reason: Clarification.

  2. #2
    Update: still the same on Unity.

    Hotfix 4, currently.

    I have to rejoin games 2-3, even 4-5 times sometimes before it works.

    Players have to do the same when I host via proxy.

    It often redirects through the proxy despite me port forwarding, and despite hosts port forwarding.

    My router does not shape traffic, for the record, and I have DDoS protection at a minimum, w/ TTS allowed through it.

  3. #3
    Update: Seems to be solved w/ 7.0 (Unity). It doesn't display any hotfixes in the version number, and it's currently April 21st, 2016. I can enter any games without issues, no lag spikes, no problem at all. Will re-post if it returns.

    To clarify: NOTHING changed on my front, the issue seemed to fix itself.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •