Page 2 of 2 FirstFirst 12
Results 26 to 40 of 40

Thread: Trying to create AssetBundle

  1. #26
    Strange finding: When adding the mesh to the top item of hierarchy, the mesh appears and functions as around 50% smaller than it is. When applying it to one of the underlying objects it's size is normal. Mysterious... But fixed by using one of the underlaying objects.
    Can you share a screenshot of your inspection panel for this setup....we might be able to spot something that's causing this odd behaviour your seeing.

    and out of curiosity are you adding your particle effects Into you Primary Assetbundle or are you adding then as a secondary Assetbundle when you load them into TTS. (neither of which is wrong )

  2. #27


    Ok, thanks for the help everybody.
    I think I got it working as well as I possibly can.
    A special thanks to Lucky Seven for answering my questions, you were a really big help.
    Here's the video (Sorry, could not resist making it a bit "showy"...).

  3. #28
    Sorry Seven. Didn't see your latest post immediately.

    Quote Originally Posted by Lucky seven View Post
    Can you share a screenshot of your inspection panel for this setup....we might be able to spot something that's causing this odd behaviour your seeing.
    'ere we go:

    Quote Originally Posted by Lucky seven View Post
    and out of curiosity are you adding your particle effects Into you Primary Assetbundle or are you adding then as a secondary Assetbundle when you load them into TTS. (neither of which is wrong )
    Everything is Primary. Effects are very specific for this Dice Tray.

    Also interesting.
    Steam WorkShop upload takes very long...?

    Update: It doesn't upload at all. TTS claims to be uploading but it is not. Waited 30 mins. Removed dicetray. Got immediately "upload done" message.
    Only empty table was uploaded. I guess the Dice Tray somehow crashes the save process of TTS?

    Another interesting point is that I am not able to save it in TTS.
    Aaand Copy/Paste still not working...

    Added the Asset bundle with the pics.
    Maybe I still messed up something...
    Last edited by Tumba; 09-22-2016 at 01:59 PM.

  4. #29
    It looks great ....but you've definitely goosed something up. that mesh colliders scale in the scene is weird for one

    I can confirm that it won't copy or save in game, so its not something at your end.

    Unfortunately I don't think you can just drop an AssetBundle back into Unity to examine its structure so its hard to say where the mistake lies.

    To have a go at unpicking the problem we'd need a Asset package of that particular project I think.

    What format did you use to import your original mesh... OBJ, FBX or something else ?

  5. #30
    Blender files directly.
    Added unity package to shared folder.

  6. #31
    The dice tray meshes have been scaled to x2 in Blender. Maybe that confuses Unity somehow...?

  7. #32
    Before exporting from Blender you should 'Apply' (Ctrl+A) the scale and rotation of the object. Most game engines don't like scaled objects.

  8. #33
    That could be the reason.... Will test tomorrow. Late here now...

  9. #34
    Its almost certain the weird behaviour is down to the way you've imported these files from blender. the package you uploaded doesn't seem to contain the meshes when it gets to me. The fact it was throwing up blender error messages when I loaded it into Unity When I'm not running blender is a tad suspicious .

    You'll probably have an easier time of it if you simply use OBJ of FBX files and export them out of blender (making sure you apply any and all transformations before you do)

    and then drop these into the Asset folder along with any textures you may be using. should be pretty straight forward to then change the links to the Meshes in the inspector panel to have your Prefabs draw from the new imports rather than the ones your using at the moment.

  10. #35
    Sorry, was only slightly aware and afraid of that.
    I just drag and drop the blender files to Unity. I think unity just links them and knows how to read them.
    There is no exporting involved.
    That way I have access to blender materials and I can see and use all the objects in the blender project.
    Exporting to something else I seemed to loose the separation of objects and always got a single object.

    I think I'll try Banbury's advise of ctrl+A as it fits perfectly to the symptoms I imagine there could be.
    Suspected it to be the reason of troubles already earlier, but didn't know about Ctrl+A.
    I'm quite sure it'll fix at least my scaling anomalies.
    Will try that later today. Now, back to my day-work...

  11. #36
    Did Control + A for location for scale and rotation.
    Now scale is ok.
    But rotation for objects is X:-90 for some reason, but they appear correctly upright in unity.
    Only the collider is on its side (X:+90)
    When I rotate the collider in blender X:-90 and ctrl+a its upright in unity and works correctly.
    No more scaling is needed so ctrl+a fixed that.
    Save still does not work.

    Summa summarum:
    The tray appears straight in Blender, it appears straight in Unity, but Unity claims all sub objects are rotation X:-90...
    Not that it matters. The tray behaves as it should in TTS.
    Just no save, nor steam upload.

    My head hurts.

    Maybe I try to rotate the tray -90 in Blender like I did for the collider, but that feels just stupid...
    + I need to realign all sub-objects... [crying (just a little bit...)]
    Could it be something else that prevents saving?

    Zipped my whole project folder in the shared folder...

  12. #37
    Quick update before anybody loses their mind over my Blender rotations.
    I think rotations do not matter.
    I removed all particle effects and saving works.
    Will experiment further...

  13. #38
    Here try adding this script into Unity.

    read the instructions as your going to need to re-import any .blend files already there for the change to take effect.

    that should take care of your rotation issue I think.

  14. #39
    Thanks Seven, will use that in future.
    At the moment I have good news. And bad.

    The Good:

    The Bad:
    No idea how it started to work.
    Here's what happened:
    0. Save didn't work.
    1. Removed all effects -> Save worked.
    2. Added each effect one by one, testing save after each addition. -> Save worked.
    3. Re positioned effects just to find the combination that breaks save -> Save worked.
    4. Seriously tried to mess up the object -> Save worked.
    5. Did a small offering to all known gods and gurus. Thanked science and took my homeopathic pills -> Save still worked.
    6. Tested copy -> Copy works.
    7. Changed bounciness to 1 and saved -> Saving did work in general, but bounciness didn't get saved, so was 0 again. Minor problem.

    I absolutely have no idea what I did or what happened, but the result can be downloaded from the above link.
    And maybe a Dev could take a look why bounciness doesn't get saved...

    Thank you everybody and hope you enjoy it.

  15. #40
    well i am doing some testing with the morph 3d assets and wile i am able to get animations onto the model i can't have them like how the default rpg models are but thats not the main issue here as you can see it's upside down as if the head was the bottom of the model. anyway to fix that?

    Fixed it as i did not have a collider it would do the weird thing
    Last edited by Gordon228; 09-28-2016 at 02:46 PM.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts