Results 1 to 13 of 13

Thread: Issue and complaints

  1. #1

    Post Issue and complaints [Solved]

    Hello,
    I am really tired of the way you guys are updating the game. It is really pissing me off, seriously.
    Every updated is followed by hotfixes. Every. I dont care that they exist, but make it look like you just compiled the code and pushed to live that may or may not be currently playing something or whatever.
    Every update also makes something stop working somewhat, some workshop game no longer work as intended or some script need some rework, etc.
    Could you please just stop? make a version then test it. Nobody, at least from my point of view, is asking for updates to be rushed out like that.

    TTS for me currently is unplayable if I join other players hosted games. I stay in a constant state of desync from a lot of stuff, cannot see my own movement of tokens, borderline see other players movements.
    When I host, people complain a about recurring lags every now and then, like some partial desync or sometimes complete desyncs seems to happend more often (so they have to reconnect).
    SINCE LAST UPDATE, everything was fine for that before it.
    Game Version: latest path
    Windows 10 pro updated to latest path
    Tried many different configurations ingame, same behavior, randomly. Verified game files.

    Anything that can be done? wait for future updates?

    Update: Solved, ISP provided bad router.
    Last edited by merovigiam; 12-01-2017 at 09:03 PM. Reason: solved

  2. #2
    Me and a handful of my friends have been having the same problem. Everyone who isn't the host is in a constant state of desync. We were forced to play our bi-monthly Pathfinder game by way of me streaming and them watching, which is not ideal for obvious reasons. I hope they get on fixing this quickly...

  3. #3
    Join Date
    Feb 2015
    Location
    The Internet
    Posts
    1,460
    I'm sorry you don't like how we update and I admit the last few updates we've had to hotfix quite frequently, but when it comes to physics objects, things can be very tricky and sometimes issues do get through the radar. And now with the networking changes, it will cause issues for some people which is why we're doing them in batches otherwise, everything will break for everyone, rather than a few people.

    We do have a beta testing group, so we have been having them test before the update goes live, but again, while they might not have had issues, it doesn't mean you won't. As every system and network is different and it's near impossible to ensure it will work for everyone right out of the box.

    Please post screenshots with the new networking commands so we can try an see what's going on with you and we'll see how we can help. We're still working on the networking, so please provide as much info as possible.

    Thanks

  4. #4
    I'm not the OP, but I've been experiencing the same problem as him. I'm not certain if this is what you're looking for, but I took a screencap while the error was on screen. I also have a DxDiag file I took while in a server experiencing this glitch which I tried to upload when I posted here, but the forums wouldn't let me because it was too large.

    20170922175959_1.jpg

  5. #5
    I have been having this problem also. I'm not sure what to post to help find the problem. Other players joining my game did not get the board updated, and were not able to move objects. stopped working after the most recent update.

  6. #6
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16
    Quote Originally Posted by merovigiam View Post
    Hello,

    TTS for me currently is unplayable if I join other players hosted games. I stay in a constant state of desync from a lot of stuff, cannot see my own movement of tokens, borderline see other players movements.

    Anything that can be done? wait for future updates?

    I have no proof of this, only speculation, as I am having desync (frozen objects, lack of control of movement) problems too on my linux install. I have a feeling this is due to the new p2p stuff, and that there might be conflicts happening that are messing up our connections. Try removing all firewall, router settings that restrict or impact p2p. I hopped on a friend's server who had no restrictions of any kind (no firewall, default gateway router settings) and all the synching problems stopped. Turn off steam voice and TTS voice and use a 3rd party voice solution like teamspeak, hangouts, discord, mumble etc etc.

    Also goes without saying remove block on VOIP as well. I don't like these solutions for security reasons but it might at least fix a game night otherwise wasted.

  7. #7
    Join Date
    May 2016
    Posts
    1,072
    For anyone looking to report issues with the new networking, when you are in game, start by typing /debug

    That will add information to the screen relating to the connection you have with the other players.

    Also check out this post, near the bottom: http://www.berserk-games.com/forums/...xed-Voice-Chat!

    It has a handful of other tweaks you can make to see how they impact performance. Basically, to help track down buts like this, they ideally need to be able to reproduce the bug. Once they can see it, it will help them track it down. I know it can be difficult, but even something like "X person joined and then their computer crashed and we started to see this error" might go a long way. And once you can replicate a bug yourself, then you can fiddle with those network tweaks to see if they help

    Basically, they never put out patches where they find bugs in their own testing (or at least I don't often see notes like "We know X doesn't work but..." haha), but it doesn't mean there aren't bugs. So helping them replicate the bug for themselves is the key to getting it fixed.

  8. #8
    Join Date
    Feb 2015
    Location
    The Internet
    Posts
    1,460
    @everyone -


    Open the following ports if you are still having connection/network issues:

    UDP 3478 (Outbound)
    UDP 4379 (Outbound)
    UDP 4380 (Outbound)

    Let us know the results, thanks!

  9. #9
    Tried many things, those 4 commands to change network setting, tried almost all of the possibilities values (both ends) when hosting or connected to someone. Also tried disabling voice chat with command and ingame (before the very last update)
    Tried to call my isp and does not look like they have any port blocks, he mentioned maybe a NAT issue (nat blocking?)
    Tried to set port forwarding in my router, didnt help. In this website http://www.canyouseeme.org/ and this https://www.yougetsignal.com/tools/open-ports/ always return "closed", have not tried for other ports yet.
    I verified that in netstat there is something listening to the port 3478 when the game is open.
    Tried to disable all firewalls i could find, router and windows, no change.
    I connected my pc to my mobile and it worked, but I cannot afford to play using that one.
    Reinstalled the game, checked integrity.

    What currently is going on is: Every game I join, I will stay "desynced", no token or thing in the table shows that i interacted with it, other players hand would not show but there are a few things that do work like changing color, interacting with counters, when something goes inside a bag it vanishes from my screen and when it comes out it comes on top of said bag and stays there, my inputs are sent to host so i do interact with everything (but still no feedback on my screen). I can write text normally.

    Apparently I can host again, did not found yet a player with those issues when connecting to me (even thou i do to any player).
    I'm using auto for both settings, nat and proxy.

  10. #10
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16
    Interestingly /debug reports absolutely no spiking events that correspond to these desyncs, not does my VPN log, which has very good support software, so I'm kind of at a loss. My ping remains well below 100 as I'm desynching in the same way OP describes. My latest debug files in this forum actually show the desynching happening though, so at least that can perhaps be traced to a solution.

  11. #11
    I meant to post this way, way before, but... life.

    TTS debug.jpg

    The 4 outside images are the debug logs on my screen while I was host with friends trying (but failing) to properly join the game and be able to interact with items. The center one one taken by one of my friends who was "in" the server, but unable to see any changes to the map that happened after his joining.

  12. #12
    So after some talks, debugs and logs with Knil, no much progress.
    Decided to swap with my older better internet router and everything worked back to normal. This new one provided by my new ISP is very.... bad.

  13. #13
    Join Date
    Oct 2017
    Location
    Australia
    Posts
    132
    Glad to see you back enjoying the game!
    Regards
    Abarden

Similar Threads

  1. [SUPPORT] sound issues in tts
    By gajeel in forum Technical Support
    Replies: 0
    Last Post: 08-09-2017, 11:39 AM
  2. Documentation/API Issues
    By Knil in forum Scripting
    Replies: 15
    Last Post: 06-13-2017, 02:03 PM
  3. [SOLVED] IRC issues?
    By WarBeer in forum Technical Support
    Replies: 6
    Last Post: 05-18-2016, 02:51 PM
  4. Copyright issues
    By ksbzw in forum General Discussion
    Replies: 9
    Last Post: 10-10-2015, 09:09 AM
  5. UI Scaling Issues
    By Dachoudono in forum General Discussion
    Replies: 3
    Last Post: 03-18-2014, 01:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •