Results 1 to 10 of 10

Thread: New p2p overhaul causing lag spikes

  1. #1
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16

    New p2p overhaul causing lag spikes

    Hi guys, I had to make a new account because the old one doesn't like to send me password e-mails.
    So far, running TTS on Linux Mint has been fine, with the exception of the keys entering extra characters (Shift inputs 0, etc.). Hope that one disappears, I know there's probabbly bigger fish right now.

    With the latest P2P migration, I'm having problems with some connections. I have P2P open on my router, I allow Steam access, everything has worked before. When I connect to a particular friend's server, or when he connects to mine, the guest gets horrible frozen spikey performance. If we both hop on a 3rd friend's hosted game (he has default everything, he knows nothing about computer stuff), neither of us have problems, so I believe it is related somehow to voice or p2p.

    - I have tried turning off voice in game.
    - I made sure P2P and all Steam ports were open on my router.
    - Confirmed integrity of game, reinstalled steam.
    - Newest drivers and generic kernel.
    - Tried OpenGL launch version at startup (it suggests its crashy, so I never choose it)
    - I have not tried disabling the Steam overlay since I primarily use Steam voice chat and it's never been a problem with TTS before. If this could be part of it I'll try it, but I doubt it is.
    - Tried not playing through VPN. I like using my VPN for all the security reasons one should, plus I don't have to mess with IRC ports and all that. Never been a problem with any game.

    My sept 13 logs differ from today's, they contain plaintext data about my IP and stuff, so I won't share those, and that connection/IP stuff has disappeared after I made some openings in my router. Almost all the noise in these logs concerns sound.
    I ran our game in debug mode, everything looked fine, until about 10 seconds of red text spam that read something about "P2P connection ... something something...", then silence. Nothing about this appears in logs.


    My logs are pretty big, 500k today alone. Kind of a pain to reduce them to this site's 20k, but most of this is noise concerning a particular shader that doesn't work in some places, almost all of it is about sound and looks like this:

    Code:
    (level_controller.cc:159): Level Controller metrics: {Max noise power: -84 dBFS, Average noise power: -84 dBFS, Max long term peak level: -10 dBFS, Average long term peak level: -10 dBFS, Max gain: 4 dB, Average gain: 0 dB, Long term peak level: -10 dBFS, Last frame peak level: -190 dBFS}
    (level_controller.cc:159): Level Controller metrics: {Max noise power: -84 dBFS, Average noise power: -84 dBFS, Max long term peak level: -10 dBFS, Average long term peak level: -10 dBFS, Max gain: 3 dB, Average gain: 0 dB, Long term peak level: -11 dBFS, Last frame peak level: -33 dBFS}
    (agc_manager_direct.cc:408): [agc] rms_error=5, target_compression=5, residual_gain=0
    (agc_manager_direct.cc:408): [agc] rms_error=10, target_compression=7, residual_gain=0
    (agc_manager_direct.cc:408): [agc] rms_error=4, target_compression=6, residual_gain=0
    (agc_manager_direct.cc:408): [agc] rms_error=4, target_compression=5, residual_gain=0
    (agc_manager_direct.cc:408): [agc] rms_error=12, target_compression=8, residual_gain=0
    (level_controller.cc:159): Level Controller metrics: {Max noise power: -84 dBFS, Average noise power: -84 dBFS, Max long term peak level: -7 dBFS, Average long term peak level: -10 dBFS, Max gain: 2 dB, Average gain: 1 dB, Long term peak leve


    Bonus help me: How deep in the icebox is the bugfix for linux users who have the metakey mapping bug, where Shift inserts 0 and stuff? Is there a workaround for this out there?

    inxi and uname
    Code:
    Linux burkenhare 4.10.0-35-generic #39~16.04.1-Ubuntu SMP Wed Sep 13 09:02:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    
    System:    Host: burkenhare Kernel: 4.10.0-35-generic x86_64 (64 bit) Desktop: MATE 1.18.0
               Distro: Linux Mint 18.2 Sonya
    CPU:       Quad core Intel Core i7-4770 (-HT-MCP-) speed/max: 3399/3400 MHz
    Graphics:  Card: NVIDIA Device 1c82
               Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
               Resolution: 2560x1600@59.97hz
               GLX Renderer: GeForce GTX 1050 Ti/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.66
    Drives:    HDD Total Size: x
    Info:      Processes: 243 Uptime: 19:24 Memory: 7001.8/32115.7MB Client: Shell (bash) inxi: 2.2.35

  2. #2
    Join Date
    Feb 2015
    Location
    The Internet
    Posts
    1,460
    I posted this in your comment in the announcement section, but here it is again for anyone else who may see this:

    Open the following ports if you are still having connection/network issues:

    UDP 3478 (Outbound)
    UDP 4379 (Outbound)
    UDP 4380 (Outbound)

    Let us know the results, thanks!

  3. #3
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16
    Thank you Kimiko! Tonight I couldn't host at all, no connection, so something got worse. I could connect to another friend's server, though I still experienced spikes of lag. These were nearly eliminated if I reduced graphics to ultra-low (unusable with games involving text), but I've never had a single problem running on High through my gigabit VPN service. With debug on, I couldn't identify any patterns. My ping remained below 100 for the most part. The only settings change I made since my last post was enabling ipv6 privacy extensions on linux connection to ISP, a pretty safe default that shouldn't hurt stuff because VPN throttles ipv6 anyway.

    I went through logs and cut out all the noise I hope, don't know if these will help at all. I have always had Steam voice ports and all other steam ports open outbound or inbound where it matters as you suggest. p2p has been enabled. Just to make sure I also enabled the steam port presets (included the ones you mentioned) on the basic linux firewall, gufw, though that has never been an issue, this didn't solve connection. Is any VOIP protocol involved? I have those blocked, but that's never stopped me from using voice on Steam. P2P completely free to come and go. I used Steam with VPN with P2P blocked on router (I don't torrent much) and it worked fine that way through the tunnel.
    Attached Files Attached Files

  4. #4
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16

    Unhappy

    Hello again, I will continue troubleshooting this and trying figure out what is happening. Unles it is against forum rules, I'll find anything new that I can.
    I ran a game in the GL version of TTS just to see how it would behave ina game, and it overwote my earlier log file before I could rename it. It is equally unrevealing regarding any network problems. I connected with a friend's server fine tonight, but still had the lag spikes.

    I tried hosting with the block of new net tools from console:
    Code:
    /networktickrate 20-120 (default 60) - this is how often the network will transmit data each second.
    /networkpackets 1-5 (default 2) - how many packets per tick to send out. Higher values make it so more objects can be synchronized each tick. (Host only command)
    /networkinterpolate 0-5 (default 1.1) - the amount of time for interpolation, increasing this value increases smoothness but also increases input lag for the clients. (Client only command)
    /networkquality 0-2 (0=high, 1=medium, 2=low) - changes the overall quality presets.
    
    
    If you are having networking issue try:
    
    
    /networkquality 2
    
     Quote Originally Posted by Kimiko View Post
    
    New networking chat commands: Prepatch above
    
        /networktickrate 20-60 (default 62.5) - this is how often the network will transmit data each second.
        /networkpackets 1-5 (default 2) - how many packets per tick to send out. Higher values make it so more objects can be synchronized each tick.
        /networkinterpolate 0-5 (default 2.1) - the number of packets that will be interpolated, increasing this value increases smoothness but also increases input lag for the clients. This is a client only command (not for the host to use).
    
    If you’re having trouble hosting, one of the things you can try:
    
    /networktickrate 30
    /networkpackets 1
    I enabled /log and /debug as well, but the logs don't mention anything about P2P, but I am getting P2P errors. See attached file. Hope I can figure this out or that the bug gets fixed. Thanks!
    Attached Images Attached Images

  5. #5
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16
    Hi, I have been actively debugging this, in case there are others out there experiencing it. The behavior is erratic. I can't connect to the friend who I could connect to before, and can connect to the other. The logs show some new issues, so I will include an edited down version with what I think is relevent to connection. Yesterday I updated my VPN host's OpenVPN UI client, which included a lot of linux fixes. Possibly there was something happening before with using outdated VPN/OpenVPN settings. After this post, I'm going to check integrity of TTS again, start a public server, and see what other logs I can get. TTS has always performed flawlessly with VPN (minus keyboard bug & some minor Nvidia hurdles). Then I will probably uninstall steam and reinstall if that doesn't work. I've also made sure ufw has ports open on p2p Steam ports as indicated by @Kimiko, though ufw firewall has not made a difference before when using VPN.

    As a reminder, system is:
    Code:
    CPU~Quad core Intel Core i7-4770 (-HT-MCP-) speed/max~3399/3400 MHz Kernel~4.10.0-35-generic x86_64 Up~15:05 Mem~4332.0/32115.7MB HDD~2000.4GB(12.3% used) Procs~252 Client~Shell inxi~2.2.35
    
    Graphics:  Card: NVIDIA Device 1c82
               Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
               Resolution: 2560x1600@59.97hz
               GLX Renderer: GeForce GTX 1050 Ti/PCIe/SSE2
               GLX Version: 4.5.0 NVIDIA 375.66

    I've inserted "comments" to indicate new log problems.
    ##Start of logs I get this same wrong ELF class thing every time.
    Code:
    ERROR: ld.so: object '/home/fernseed/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Setting breakpad minidump AppID = 286160
    Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198113343519 [API loaded no]
    (audio_processing_impl.cc:680): Level controller activated: 1
    (audio_processing_impl.cc:687): Highpass filter activated: 1
    (audio_processing_impl.cc:680): Level controller activated: 1
    (audio_processing_impl.cc:687): Highpass filter activated: 1
    (agc_manager_direct.cc:351): [agc] Initial GetMicVolume()=0
    (agc_manager_direct.cc:356): [agc] Initial volume too low, raising to 12
    (agc_manager_direct.cc:408): [agc] rms_error=3, target_compression=5, residual_gain=0
    (agc_manager_direct.cc:408): [agc] rms_error=-1, target_compression=4, residual_gain=-3
    (level_controller.cc:159): Level Controller metrics: {Max noise power: -72 dBFS, Average noise power: -77 dBFS, Max long term peak level: -3 dBFS, Average long term peak level: -6 dBFS, Max gain: 6 dB, Average gain: 2 dB, Long term peak level: -3 dBFS, Last frame peak level: -101 dBFS}
    Here are some snippets from lattest log, I was unable to host from connection problems that night:
    
    ###
    ### I got a lot of this, dropped mic samples. My friends said I was cutting out sporadically on mic. This has been the case since the big p2p ###patch.
    
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] BasePreprocessingPipeline: Failed to write microphone samples into input queue
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] MicrophoneCapture: Insufficient buffer space, requested 23553, clamped to 16383 (dropping samples)
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] BasePreprocessingPipeline: Failed to write microphone samples into input queue
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] BasePreprocessingPipeline: Failed to write microphone samples into input queue
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] BasePreprocessingPipeline: Failed to write microphone samples into input queue
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    
    ##
    ##This is new too, seeing the reject late packets. I tried adjusting packet size with new
    ## /netpacket commands but these did not seem to help with performance.
    ##
    
    
    Unloading 0 Unused Serialized files (Serialized files now loaded: 5)
    
    Unloading 120 unused Assets to reduce memory usage. Loaded Objects now: 73737.
    Total: 82.988998 ms (FindLiveObjects: 5.122000 ms CreateObjectMapping: 0.597000 ms MarkObjects: 76.792999 ms  DeleteObjects: 0.476000 ms)
    
    Reject late object packet
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Reject late object packet
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    View ID AllocatedID: 1485 not found during lookup. Strange behaviour may occur
     
    (Filename:  Line: 1716)
    
    Could't invoke RPC function 'RPCResetInfiniteBag' because the networkView 'AllocatedID: 1485' doesn't exist
     
    (Filename:  Line: 2518)
    
    Auto UnloadUnusedAssets and Sync achievements
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Unloading 0 Unused Serialized files (Serialized files now loaded: 5)
    
    Unloading 74 unused Assets to reduce memory usage. Loaded Objects now: 73653.
    Total: 85.888000 ms (FindLiveObjects: 5.778000 ms CreateObjectMapping: 0.763000 ms MarkObjects: 78.985001 ms  DeleteObjects: 0.361000 ms)
    
    Fix layer!
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Auto UnloadUnusedAssets and Sync achievements
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Unloading 0 Unused Serialized files (Serialized files now loaded: 5)
    Fix layer!
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    
    Unloading 44 unused Assets to reduce memory usage. Loaded Objects now: 73899.
    Total: 81.107994 ms (FindLiveObjects: 5.706000 ms CreateObjectMapping: 0.591000 ms MarkObjects: 74.587006 ms  DeleteObjects: 0.223000 ms)
    
    ###
    ###  Here is a good snippet of disconnecting from a server. 
    ###
    
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] BasePreprocessingPipeline: Failed to write microphone samples into input queue
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    bNeedToUpdate
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    The server has disconnected from the client. Most likely the server has shut down.
     
    (Filename:  Line: 776)
    
    Unity Analytics: Multiplayer_Ended
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    On Disconnected From Server: Disconnected
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Leave lobby success
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Network] SteamVoiceP2PClient: Disconnected
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    [Dissonance:Recording] BasePreprocessingPipeline: Disposed pipeline
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Auto UnloadUnusedAssets and Sync achievements
     
    (Filename: /home/builduser/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
    
    Unloading 1 Unused Serialized files (Serialized files now loaded: 5)
    
    Unloading 40 unused Assets to reduce memory usage. Loaded Objects now: 73549.
    Total: 80.651001 ms (FindLiveObjects: 4.842000 ms CreateObjectMapping: 0.515000 ms MarkObjects: 75.101006 ms  DeleteObjects: 0.193000 ms)
    
    The referenced script on this Behaviour (Game Object 'WebCoreInputController') is missing!
     
    (Filename:  Line: 1743)
    
    Unloading 4 Unused Serialized files (Serialized files now loaded: 5)
    ResetCardManager

  6. #6
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16
    Noticed a few things tonight for persisting Linux connection issue:
    No matter what my settings are TTS launches lots of pulseaudio sessions. I disabled Steam overlay, I seem to get the same logs and performance.
    Performance issues remain: synching/stuttering/frozen movement, cutting out on voice erratically in Steam chat, erratic connection to servers; sometimes I can connect and sometimes I can't. Hosting needs more testing but connectivity is erratic here too.

    Another thing that I think might make me look like an idiot: I have propietary Nvidia drivers, keeping
    Nvidia Xserver Open forces GL activity in the logs, though not sure what it's doing. I'm wondering if connectivity issues are mixed up with graphical issues. I had no problems with graphics before p2p update though. This might seem obvious, but nothing in the Nvidia X server docs say you have to keep the GUI open for the settings to remain active (though they reset when I log out).

    Note different log loadout when I open a mod:

    Code:
    ERROR: ld.so: object '/home/fernseed/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Setting breakpad minidump AppID = 286160
    Steam_SetMinidumpSteamID:  Caching Steam ID:  76561198113343519 [API loaded no]
    :     0
     GL_AMD_multi_draw_indirect GL_AMD_seamless_cubemap_per_texture GL_AMD_vertex_shader_viewport_index GL_AMD_vertex_shader_layer GL_ARB_arrays_of_arrays GL_ARB_base_instance GL_ARB_bindless_texture GL_ARB_blend_func_extended GL_ARB_buffer_storage GL_ARB_clear_buffer_object GL_ARB_clear_texture GL_ARB_clip_control GL_ARB_color_buffer_float GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_compute_shader GL_ARB_compute_variable_group_size GL_ARB_conditional_render_inverted GL_ARB_copy_buffer GL_ARB_copy_image GL_ARB_cull_distance GL_ARB_debug_output GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_derivative_control GL_ARB_direct_state_access GL_ARB_draw_buffers GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_enhanced_layouts GL_ARB_ES2_compatibility GL_ARB_ES3_compatibility GL_ARB_ES3_1_compatibility GL_ARB_ES3_2_compatibility GL_ARB_explicit_attrib_location GL_ARB_explicit_uniform_location GL_ARB_fragmen
    t_coord_conventions GL_ARB_fragment_layer_viewport GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_fragment_shader_interlock GL_ARB_framebuffer_no_attachments GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_geometry_shader4 GL_ARB_get_program_binary GL_ARB_get_texture_sub_image GL_ARB_gl_spirv GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader_int64 GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_indirect_parameters GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_invalidate_subdata GL_ARB_map_buffer_alignment GL_ARB_map_buffer_range GL_ARB_multi_bind GL_ARB_multi_draw_indirect GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_occlusion_query2 GL_ARB_parallel_shader_compile GL_ARB_pipeline_statistics_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_post_depth_coverage GL_ARB_program_interface_query GL_ARB_provoking_vertex GL_ARB_query_buffe
    r_object GL_ARB_robust_buffer_access_behavior GL_ARB_robustness GL_ARB_sample_locations GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_seamless_cubemap_per_texture GL_ARB_separate_shader_objects GL_ARB_shader_atomic_counter_ops GL_ARB_shader_atomic_counters GL_ARB_shader_ballot GL_ARB_shader_bit_encoding GL_ARB_shader_clock GL_ARB_shader_draw_parameters GL_ARB_shader_group_vote GL_ARB_shader_image_load_store GL_ARB_shader_image_size GL_ARB_shader_objects GL_ARB_shader_precision GL_ARB_shader_storage_buffer_object GL_ARB_shader_subroutine GL_ARB_shader_texture_image_samples GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shader_viewport_layer_array GL_ARB_shading_language_420pack GL_ARB_shading_language_include GL_ARB_shading_language_packing GL_ARB_shadow GL_ARB_sparse_buffer GL_ARB_sparse_texture GL_ARB_sparse_texture2 GL_ARB_sparse_texture_clamp GL_ARB_stencil_texturing GL_ARB_sync GL_ARB_tessellation_shader GL_ARB_texture_barrier GL_ARB_texture_border_clamp GL_AR
    B_texture_buffer_object GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_buffer_range GL_ARB_texture_compression GL_ARB_texture_compression_bptc GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_cube_map_array GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_filter_minmax GL_ARB_texture_float GL_ARB_texture_gather GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_mirrored_repeat GL_ARB_texture_multisample GL_ARB_texture_non_power_of_two GL_ARB_texture_query_levels GL_ARB_texture_query_lod GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_texture_rgb10_a2ui GL_ARB_texture_stencil8 GL_ARB_texture_storage GL_ARB_texture_storage_multisample GL_ARB_texture_swizzle GL_ARB_texture_view GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_transform_feedback_instanced GL_ARB_transform_feedback_overflow_query GL_ARB_transpose_matrix GL_ARB_uniform_buffer_object GL_ARB_vertex_array_bgra GL_ARB_vertex_ar
    ray_object GL_ARB_vertex_attrib_64bit GL_ARB_vertex_attrib_binding GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_vertex_type_10f_11f_11f_rev GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_
    float GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset_clamp GL_EXT_post_depth_coverage GL_EXT_provoking_vertex GL_EXT_raster_multisample GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_shader_objects GL_EXT_separate_specular_color GL_EXT_shader_image_load_formatted GL_EXT_shader_image_load_store GL_EXT_shader_integer_mix GL_EXT_shadow_funcs GL_EXT_sparse_texture2 GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_filter_minmax GL_EXT_texture_integer GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode G
    L_EXT_texture_storage GL_EXT_texture_swizzle GL_EXT_timer_query GL_EXT_transform_feedback2 GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_EXT_vertex_attrib_64bit GL_EXT_window_rectangles GL_EXT_x11_sync_object GL_EXT_import_sync_object GL_NV_robustness_video_memory_purge GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KHR_context_flush_control GL_KHR_debug GL_KHR_no_error GL_KHR_robust_buffer_access_behavior GL_KHR_robustness GL_KTX_buffer_region GL_NV_alpha_to_coverage_dither_control GL_NV_bindless_multi_draw_indirect GL_NV_bindless_multi_draw_indirect_count GL_NV_bindless_texture GL_NV_blend_equation_advanced GL_NV_blend_equation_advanced_coherent GL_NVX_blend_equation_advanced_multi_draw_buffers GL_NV_blend_square GL_NV_clip_space_w_scaling GL_NV_command_list GL_NV_compute_program5 GL_NV_conditional_render GL_NV_conservative_raster GL_NV_conservative_raster_dilate GL_NV_conservative_raster_pre_snap_triangles GL_NV_copy_depth_to_color GL_NV_copy_image GL_NV_depth_buffer_float GL_NV_depth_clamp GL_
    NV_draw_texture GL_NV_draw_vulkan_image GL_NV_ES1_1_compatibility GL_NV_ES3_1_compatibility GL_NV_explicit_multisample GL_NV_fence GL_NV_fill_rectangle GL_NV_float_buffer GL_NV_fog_distance GL_NV_fragment_coverage_to_color GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_fragment_program2 GL_NV_fragment_shader_interlock GL_NV_framebuffer_mixed_samples GL_NV_framebuffer_multisample_coverage GL_NV_geometry_shader4 GL_NV_geometry_shader_passthrough GL_NV_gpu_program4 GL_NV_internalformat_sample_query GL_NV_gpu_program4_1 GL_NV_gpu_program5 GL_NV_gpu_program5_mem_extended GL_NV_gpu_program_fp64 GL_NV_gpu_shader5 GL_NV_half_float GL_NV_light_max_exponent GL_NV_multisample_coverage GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_parameter_buffer_object2 GL_NV_path_rendering GL_NV_path_rendering_shared_edge GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_sample_loca
    tions GL_NV_sample_mask_override_coverage GL_NV_shader_atomic_counters GL_NV_shader_atomic_float GL_NV_shader_atomic_float64 GL_NV_shader_atomic_fp16_vector GL_NV_shader_atomic_int64 GL_NV_shader_buffer_load GL_NV_shader_storage_buffer_object GL_NV_stereo_view_rendering GL_NV_texgen_reflection GL_NV_texture_barrier GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_multisample GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_transform_feedback GL_NV_transform_feedback2 GL_NV_uniform_buffer_unified_memory GL_NV_vdpau_interop GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_attrib_integer_64bit GL_NV_vertex_buffer_unified_memory GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2 GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NV_viewport_array2 GL_NV_viewport_swizzle GL_NVX_conditional_render GL_NVX_gpu_memory_info GL_NVX_nvenc_interop GL_NV_shader_thread_group GL_NV_shader_thread_shuffle GL_KHR_blend_equatio
    n_advanced GL_KHR_blend_equation_advanced_coherent GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
    https://s1.postimg.org/10spaequ5b/ta...ndproblems.jpg
    Last edited by burkenhare; 10-16-2017 at 05:09 AM.

  7. #7
    Join Date
    Jan 2014
    Posts
    985
    Hi there are you or the people connected to you getting a bad connection icons next to the names?

  8. #8
    Join Date
    Sep 2017
    Location
    Flampton, Ferpijerp City, New Scumlund
    Posts
    16
    Quote Originally Posted by Knil View Post
    Hi there are you or the people connected to you getting a bad connection icons next to the names?
    Hi Knil, I tried hosting tonight, somewhat of a disaster, both players get endless loading loops at the lobby, no connection at all, no hosting. I've been hopping around open servers and connecting to games just fine for the most part, but still have the jerky movement issues. I have seen a bad connection icon with a player I couldn't connect to (and vice versa), but it disappeared in another game (we couldn't connect that night either), so I'm not sure if it always indicates whatever problem is happening. I have all steam ports opened as instructed both here and on the Steam port configuration page:
    https://support.steampowered.com/kb_...8571-GLVN-8711

    Besides, I have always connected to steam via VPN and everything has worked perfectly across the board. I might have to do a naked test with no router, firewall, vpn as a last resort. I do have a router with stateful firewall/packet filtering, and there might be an advanced feature that is now suddenly complicating matters. I just tried flicking off a QoS feature I don't really need, who knows.

    I keep debug and logging on when testing. Debug shows no sign of packet problems (spikes etc), my ping remains below 100. My problem might be a combination of a few things happening at once, as I mentioned on Discord.

  9. #9
    Join Date
    Jun 2017
    Location
    Argentina
    Posts
    32
    delete me
    Last edited by francogp; 04-14-2018 at 01:34 AM.

  10. #10
    Join Date
    Jun 2017
    Location
    Argentina
    Posts
    32
    Quote Originally Posted by Kimiko View Post
    I posted this in your comment in the announcement section, but here it is again for anyone else who may see this:

    Open the following ports if you are still having connection/network issues:

    UDP 3478 (Outbound)
    UDP 4379 (Outbound)
    UDP 4380 (Outbound)

    Let us know the results, thanks!
    Quote Originally Posted by Knil View Post
    Hi there are you or the people connected to you getting a bad connection icons next to the names?
    Hello, I'm having this issue... 400+ ping since this patch. We cannot play anymore. With the old system we could play at 18-25 ping... now 400+. We have all port forwarded like you said. All players use 30mb speed connection minimum. Something is REALLY wrong.

Similar Threads

  1. Replies: 10
    Last Post: 12-19-2016, 08:49 PM
  2. [UPDATE] Update v6.7 Scythe DLC, 10 Players, and Scripting Overhaul!
    By Kimiko in forum Announcements
    Replies: 5
    Last Post: 02-28-2016, 12:30 AM
  3. Replies: 2
    Last Post: 10-24-2014, 06:52 PM
  4. Replies: 3
    Last Post: 10-04-2014, 03:15 AM
  5. Replies: 3
    Last Post: 08-17-2014, 01:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •