Results 1 to 7 of 7

Thread: Hosting and/or joining is a no-go

  1. #1

    Exclamation Hosting and/or joining is a no-go

    So since the release of the patch that was meant to fix networking issues mine & the friend I play with have only gotten worse. At least b4 we could attempt to play through the lag & the other BS now we can't even connect properly. It started with not being able to connect at all the "kicked" error, then came the hotfixes & now when I join a game, any game hosted by anyone, all I get is a blurred background & the choose a color text but the only color is gray and I can't even choose it. One time I sat there for a good 5+ mins while I was searching to help & it did eventually let my pick spectator(i'm guessing cause all the spots where taken by then). But I still only had the blurred BG & I saw some "unfinished", best I can call it, items moving on a what was suppose to be a Hero Quest game. The object were a couple of dots and blank white cards. The dots if I hovered over one had a description I believe, treasure 'somthing' but that's it.

    When my friend tries to join my hosted game even if I haven't loaded a game yet just the default empty table he gets the blurred BG and the choose color gray only thing. And even when I assigned him a color & promoted him nothing changed. We closed TTS & Steam multiple times and restarted. The best we got was one time when it asked him to choose a color he had multiple options and when he would pick a color I'd see him change to that color and his avatar move to it but he wouldn't. I'm not getting any errors in the chat box nor am I crashing.

    I've asked for help in chat, on the steam discussions, & on the discord official channel & got nothing. On discord an admin started to respond to me but then never continued the chat. We bought TTS over Fantasy Grounds for its customization and features to play D&D and now we finally got a group of 3.5 players, which apparently is a dying breed, & we haven't been able to even kick off the campaign because of this "wonderful" patch. SO PLEASE HELP!!!!!!!!!

    Here is a link to the screen shot and a link to the log.

    When I join :

    When I'm finally able to click spectate:

    And the log : https://drive.google.com/file/d/1phQ...ew?usp=sharing
    (file is set to allow anyone to view)

  2. #2
    Join Date
    Jan 2014
    Posts
    986
    Thanks for the report we are investigating this issue. Does it work better or worse if you swap who is hosting?

  3. #3
    It doesn't matter who is hosting. The best attempt I had in joining when my friend hosted was a game of checkers where I could see the table, board, pieces, but couldn't interact with anything and there wasn't any names in the top right corner on the screen like there would normally be. It kept saying "click your name and choose a color" but I couldn't since I couldn't see the names. My friend, the host, could assign me but it didn't work.

    UPDATE: I just tried joining 2 different games. Chess - got a white BG with the choose color option. Gray in the middle & all the other colors clumped together...nothing happened no when I tried to click on one. The second game was checkers only 2 players me and the host. Could see the checker board and pieces and the host hand Colors were around the table but still not clickable. Tried chatting in game tab of the chat box...couldn't.
    Last edited by Fenrys; 11-20-2017 at 07:02 PM.

  4. #4
    After the latest hotfix 6 I'm actually worse off. Back to trying to connect and then getting the the kick message or it connects and gives me the same screen as above, or I get to see the table and the starting of objects but I can't choose a color, talk in game chat, or interact with objects. And the /networkbuffering thing didn't do anything. Didn't even give a response in chat when I entered it


    New log file from today here

  5. #5
    Join Date
    Jan 2014
    Posts
    986
    Hey Fenrys we are still working on this issue it's the last of the networking problems we hope to have it solved soon!

  6. #6
    Hey devs, are you sure it's connection issue rather than bugged color picker code?

    Today a friend of mine got this very same bug in single player tutorial. Stuck on choosing color and no player name in the upper right corner. The only new thing is that now it happened in the tutorial.

    This bug has been plaguing half my friends. We can't play because they get stuck on choosing color. Sometimes it's possible to join their game and pick colors, but not the other way around.

    Searching for solutions only shows multiple consistent reports here and on reddit. Some of those reports are already several years old. And this thread is the only report with ANY dev input in it. I only registered because of that.

    It's surprising and frustrating that this bug was never fixed.

    However, apparently it also occurs in single player.

    So perhaps it has nothing to do with networking and you are investigating wrong parts of the code?

    My guess would be that under some very odd circumstances Tabletop Simulator fails to build the player list and consequently side choosing goes crazy for the affected player (everybody else typically sees their color change, it just doesn't register on their machine, because player list fails to build for them).

  7. #7
    Join Date
    Jan 2014
    Posts
    986
    Can you friends turn on logging with launch option -log and send over their log when they run into this issue.

Similar Threads

  1. [CRASHES] Chares on Hosting Single & Multiplayer, but not Joining
    By Sand4839 in forum Technical Support
    Replies: 1
    Last Post: 05-06-2017, 05:32 PM
  2. [SOLVED] Keep crashing when joining a friend's server
    By UncreativeUsername in forum Technical Support
    Replies: 3
    Last Post: 02-16-2016, 12:31 PM
  3. joining cards?
    By Jabrwock in forum General Discussion
    Replies: 3
    Last Post: 11-13-2015, 09:05 AM
  4. Idea for joining a game
    By UsF in forum General Discussion
    Replies: 0
    Last Post: 05-09-2014, 07:10 AM
  5. Joining/hosting
    By ninjaguard in forum General Discussion
    Replies: 1
    Last Post: 04-23-2014, 03:33 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •