Results 1 to 5 of 5

Thread: Atom TTS Lua Package Error - Cannot read property 'match' of undefined

  1. #1

    Atom TTS Lua Package Error - Cannot read property 'match' of undefined

    Starting last week (same exact time when Atom and TTS stopped communicating for me), I also started getting an error that I can't seem to debug within my code. The error seems to be coming out of a coroutine, but even if I comment everything out inside the coroutine, the error still occurs. I'm thinking something got messed up within the tabletopsimulator_lua package for Atom. So, onelivesleft - this one is for you. Here's the error as an image (copy/paste formatting was terrible):
    Attached Images Attached Images
    Last edited by Prattski; 06-01-2018 at 11:24 AM. Reason: Had an extra error in the screenshot that was irrelevant. Screenshot link updated

  2. #2
    Hey Prattski,

    I have exactly the same issue you are having. Have you made any progress on resolving this issue?

  3. #3
    I'm still getting the issue - and I can't figure out a way to even debug it since it seems to be coming out of the tabletopsimulator-lua package.

  4. #4
    There is an error in the script listed in the first error message; the error report to atom isn't managing to include details about it which is causing the second error message. We're looking at fixing the latter: can you post the code of the former?

  5. #5
    @onelivesleft -

    The script I have is quite huge, but the code in question is simple:

    function onObjectEnterScriptingZone(zone, enter_object)
        -- Make sure to only run when it's this inventory's scripting zone
        if zone.getGUID() == inventoryZoneGUID then
            objectEnteringZone = enter_object
        	startLuaCoroutine(self, 'scriptingZoneEnterCoroutine')
    function scriptingZoneEnterCoroutine()
    Everything within the scriptingZoneEnterCoroutine() is commented out, and the error still occurs. The function DOES run, however. If I put a print("Test") in there, it does print to the chat window. I just have no idea if there's something wrong within the tabletopsimulator-lua package code, or if there's something somewhere else in the code that's causing it (I don't know what else it would be though, as these two functions are the only thing that should be firing here...).

Similar Threads

  1. [SUPPORT] Error Steam read form workshop:
    By DJHeroMasta in forum Technical Support
    Replies: 4
    Last Post: 07-15-2018, 05:48 PM
  2. Permission Error Atom Cant save more than one time
    By auoryus in forum Scripting Bug Reports
    Replies: 2
    Last Post: 03-31-2018, 10:18 AM
  3. Replies: 1
    Last Post: 11-27-2017, 06:28 PM
  4. [SOLVED] Microsoft Visual C++ 2010 Redistributable Package (x86) (not working)
    By mariowittberger in forum Technical Support
    Replies: 5
    Last Post: 01-06-2017, 03:10 PM
  5. [SOLVED] Controls don't match tutorial
    By TheNomadPanda in forum Technical Support
    Replies: 2
    Last Post: 07-31-2015, 03:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts