Results 1 to 4 of 4

Thread: TTS freezes when loading a game

  1. #1

    Not Actually Solved: TTS freezes when loading a game

    OS: macOS 10.14.2 (18C54)
    3.2 GHz Intel Core i7
    32 GB 2667 MHz DDR4
    Radeon RX 580 8192 MB

    Tabletop Simulator v11.0.1
    Unity Player version 5.6.6f2 (6bac21139588).

    Steps to reproduce:
    1. Start Tabletop Simulator
    2. Press "Create" on main menu
    3. Press "SINGLEPLAYER"
    4. Load a game, such as "Tiny Epic Kingdom"

    Result: macOS beachball cursor. No alternative but to force quit Tabletop Simulator

    I don't recall if the issue's appearance coincided exactly with updating to macOS 10.14.2 from 10.14.1, but it might have

    The issue happens when creating multiplayer and hotseat games, not just single player. I haven't tried joining any games.

    Loading any workshop mod or save file has the same result, beachballing after clicking "Load" in the "Are you sure" dialog, but some DLC will successfully load sometimes (Mistfall, Time Epic Galaxies). Loading the built-in games like checkers seems to work often, but not always.

    There's also an issue with the audio: as soon as the "single player" button is clicked the audio starts looping and the Player.log file mentions a NULL exception. The game doesn't freeze at this point and I can continue clicking around the game selection screen.

    ( Level controller activated: 1
    ( Highpass filter activated: 1
    Receiving unhandled NULL exception
    Obtained 3 stack frames.
    ( Level controller activated: 1
    ( Highpass filter activated: 1

    The Player.log doesn't seem to show anything useful at the time of the freeze, it just stops.

    I tried the flags “-nothreading” “-nosteam” “-notablet” “-nosubscription”. None had any positive effect. -nosteam just stops me from getting to the point where the issue would reproduce. The freeze occurred with all the other flags.

    After restarting Steam the freeze continued to manifest.
    Also after restarting the computer.
    Also after reinstalling Tabletop Simulator.
    Also after deleting the preferences file unity.Berserk Games.Tabletop Simulator.plist
    Verifying integrity of game files reported no issues
    Last edited by Bamed; 12-18-2018 at 03:23 PM. Reason: Turns out the problem didn't go away.

  2. #2
    And never mind. The issue persisted for a few dozen repeats while I tried things out, then I spent a few hours doing something else and now the problem is gone.

  3. #3
    This must be the only solved problem on this board within the last 6 months.

  4. #4
    Nope, it's back. It seems the freezing is connected to the audio issue. If the audio output is set to go to headphones then I don't get the looping audio effect and then I don't get any freezes later on. If the audio is set to the built-in speakers then I get the audio looping, the NULL exception in the log, and then sometime later TTS will freeze and have to be force quit.

Similar Threads

  1. [CONNECTION ISSUES] Players' game freezes, host's game continues just fine
    By Psycho Romeo in forum Technical Support
    Replies: 10
    Last Post: 08-27-2016, 02:48 PM
  2. [SOLVED] Game launches fine but freezes once I join
    By insidatori in forum Technical Support
    Replies: 1
    Last Post: 08-09-2016, 02:41 PM
  3. [SOLVED] Game freezes on launch
    By Kultinator in forum Technical Support
    Replies: 0
    Last Post: 02-07-2016, 09:33 PM
  4. [SOLVED] Game Freezes When Trying to Load Server Browser
    By Dr Palazzo in forum Technical Support
    Replies: 0
    Last Post: 01-26-2016, 05:41 PM
  5. [SOLVED] Game freezes (Not Responding) when loading into game (Win7)
    By LordPenguin in forum Technical Support
    Replies: 1
    Last Post: 05-25-2015, 01:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts