Results 1 to 4 of 4

Thread: AssetBundle states doesn't work

  1. #1

    [SOLVED] AssetBundle states doesn't work

    Greetings. I'm working on a mod now and I thought it would be cool to make it possible to change the pose of the figure. For this purpose I made 2 different models with different colliders, but when I tried to implement the idea in Unity it just didn't work. I used CHRYs Guide to Asset Creation Part 3 as a reference and here's what I did:
    1. In viewport created 2 different objects, each was one of the supposed states. Both objects use the same material.
    2. Pulled these 2 objects from the Hierarchy tab into Project.
    3. Added the TTSAssetBundleEffects script to the first object that is supposed to be the first possible state.
    4. Added 2 looping effects and for each, in Game Objects I picked one of those previously saved objects, that I got on step 2.
    5. Pulled the object with effecs script out of the Hierarchy into Prefab folder and saved as an AssetBundle.

    After these steps, when I load it in the game I see the mesh of the first possible state, all looks good, in the sub menu there are 2 possible states, but if I pick the second one, the mesh will stay the same, even tho in the script I used a different one for that state. Just in case, here are the settings of each object. First two are state objects and the last one is the final one


    What do I do to make it work properly? What I want to get is something similar to the Mode thingy that figures from the RPG Kit have, just without the animation. Any advice is greatly appreciated.
    Last edited by OverSavior; 05-26-2019 at 03:35 PM.

  2. #2
    Wow actually i loved your blog man..Thanks for sharing awesome content.

    videoder ios online notepad++ psiphon pro
    Last edited by isoman; 05-30-2019 at 05:44 AM.

  3. #3
    I don't have any blogs. You probably mistaken me for someone else : )
    Also, I solved the issue. Appears that I was linking objects from the hierarchy to the script, not saved prefabs. Now it works perfectly.

  4. #4
    This Content is very nice and informative thanks for sharing. And I want you to read my blog also by click on given links:-

Similar Threads

  1. [SUPPORT] Microphone doesn't work in-game
    By hurukpt in forum Technical Support
    Replies: 0
    Last Post: 03-07-2019, 10:32 AM
  2. [CRASHES] Game doesn't work
    By joaopedrow in forum Technical Support
    Replies: 1
    Last Post: 07-20-2017, 12:03 PM
  3. Replies: 3
    Last Post: 08-28-2016, 07:26 PM
  4. Caching does not work for objects with states
    By Huffel in forum Bug Reports
    Replies: 6
    Last Post: 06-07-2016, 10:25 AM
  5. [SOLVED] Model Scaling Doesn't Work
    By BinaryCodex in forum Technical Support
    Replies: 3
    Last Post: 05-25-2015, 01:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts