Results 1 to 8 of 8

Thread: My mod is marked as "incompatible" and is delisted from the workshop search

  1. #1

    Unhappy My mod is marked as "incompatible" and is delisted from the workshop search

    I already posted this on Steam but I copy pasta it here too, since it is recommended in the Steam forum.
    Steam forum support request

    This month I got an email that informed me, that my "Secret Hitler" mod was "incompatible" for some reason, though it still keeps working just fine for me and others. This is especially weird since many other mods have copied my mod (to be clear, I am not complaining about that) and added on top of it additional content like automation through the integrated lua programming, or additional assets. If their mods are not marked "incompatible" then why is my mod with no coding and less assets marked "incompatible"? It makes absolutely no sense!

    Secret Hitler Steam workshop mod link

    This is the email I got from Steam:

    Dear d1oftwins,

    Thank you for your Steam Workshop Contribution Secret Hitler.

    Unfortunately, for various reasons, the developers of "Tabletop Simulator" had to flag it as "incompatible", so it cannot be used within "Tabletop Simulator".

    You can learn more about what kinds of items are accepted and why certain items are marked as "incompatible" here: http://tabletopsimulator.gamepedia.c...Simulator_Wiki

    The Steam Support Team

    I'd like to know what is going on with this claim and somehow I doubt the devs have marked it as "incompatible" but rather that was an automated mess of some sort. The link to the wiki page is absolutely unrelated to the specific issue and does not explain anything. I would like a more precise explanation than the link in the email gave me, also I would like to know why my mod is delisted from the workshop search? It might have to do with that my mod was flagged as "incompatible" and therefore unsearchable, if so, it is more of a reason to remove this improper flag!

  2. #2
    Is it possible that:

    1) Some of your files where local hosted instead of cloud hosted


    2) Hosted on a service that no longer host them

  3. #3
    I would be glad if that would be the problem, so I could fix it easily myself. The files are hosted by a friend on a private server. The availability is still there, I tested it with mod caching off. But thanks for at least trying to help. You can test it for yourself, just use the link to the mod above, install it, and you will see it will work just fine, there are no fancy scripts to cause problems, just props. Of course, if it doesn't work for you, you could tell me, or even if it does work you could tell me too, just to reassure me that is not the problem.

  4. #4
    I subscribed to the Workshop just to see if I could see some obvious error but I didn't see anything that would cause it to be flagged as "incomplete". Odd.

  5. #5
    Well yeah, odd, that is what came to my mind as well. Thanks for testing.

  6. #6
    I wonder if you just re-post it under a new title if it will still get flagged as incomplete...

  7. #7
    Most likely it would work since it would get a new ID. And it is not like the mod doesn't work either. But the point is that it was for years all good, the mod is not complicated in any way to cause incompatibilities, it is the most basic it can be. I want to know the conditions that cause that issue which I still don't get to know. Yeah, that sounds stubborn, but that's me I guess.

  8. #8
    The only thing I can think of is that it uses some Script function which is depreciated or some assetBundle feature that is depreciated. Nothing that I saw obviously but it was probably a bot that put 2 and 2 together and got 5.

Similar Threads

  1. Workshop "Plays" count (and a Game Start button)
    By Unreal_Ed in forum Suggestions
    Replies: 5
    Last Post: 07-18-2018, 11:21 AM
  2. [SOLVED] Literally nothing works in my game if I try to host and choose "Workshop"
    By mdrxd100 in forum Technical Support
    Replies: 4
    Last Post: 12-14-2015, 07:46 PM
  3. [SOLVED] "Search Deck" functionality is broken sometimes
    By agheno in forum Technical Support
    Replies: 4
    Last Post: 08-17-2015, 02:21 PM
  4. Removing "removed workshop items" from game.
    By GoldKnight in forum General Discussion
    Replies: 9
    Last Post: 06-24-2015, 09:04 PM
  5. [ADDED] Search tool: "Show threads with unread posts" / "show active threads"
    By Keybounce in forum Forum & Website Help
    Replies: 1
    Last Post: 03-08-2015, 09:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts