Results 1 to 3 of 3

Thread: Game won't launch at latest version

  1. #1

    Game won't launch at latest version

    Whenever I tried to launch game, it simply showes nothing, not even an error message. And when I tried to start the game again, Steam tells me the game is already running, and I could see and close it in task manager, but still nothing happens.(is that called a silent crash? I found a steam help page told me so.)

    I tried a DX9 version (hotfix3 v10.8.1)which I got from a steam command, and it works perfectly fine, but it can't reach the network so I still need the latest version.

    My system is at latest update of windows 10, and I have already installed the latest Graphic drivers etc. And the Graphic card is GTX1070, CPU is i5 4590 so those shouldn't be the problem.

    update:I've tried all of the trouble shooting method I could found on the internet and forum but non of them help. Including
    1 reinstalled the game, steam, rebooted computer hundreds of times.
    2 verified and reinstalled the game, driver, C++ packages several times
    3 turned off all Anti-virus and firewall software
    4 used -nosteam, -nothreading, -nosubscription, -windows launch options
    5 set the .exe file to the compatibility mode.
    6 tried to use the -log option, and it didn't print me a log either.

    and I also tested my computer with another DX11-only game called rolling sun, which runs smoothly.
    Last edited by Swanfal; 08-27-2019 at 09:56 AM.

  2. #2
    I am also having problems launching the game, where it freezes prior to getting to the main menu screen.

  3. #3
    I am having this issues as well.

Similar Threads

  1. Game Controller Issue after latest Update
    By ArmodaXP in forum Bug Reports
    Replies: 3
    Last Post: 09-12-2017, 07:09 PM
  2. [SOLVED] Game keeps crashing after latest update
    By Swimlee in forum Technical Support
    Replies: 8
    Last Post: 08-25-2017, 11:05 PM
  3. Replies: 2
    Last Post: 08-07-2017, 04:46 PM
  4. [SOLVED] Game won't Launch?
    By SamwiseDB in forum Technical Support
    Replies: 1
    Last Post: 10-26-2016, 11:29 AM
  5. [SOLVED] In latest release, crashing on launch [in Linux]
    By SmileyChris in forum Technical Support
    Replies: 2
    Last Post: 09-29-2015, 08:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •