I've had TTS for quite a while now but recently it's been refusing to work. The game loads up the "Berserk Games" intro and then crashes about halfway through loading the menu. I'd like to figure out why but all the things I've tried haven't worked. My mac is a 2012 so it's a little old but according to the app store the software is up to date. The game displays no error message, it just closes.

I've tried:
verifying game files (they're fine apparently)
uninstalling and reinstalling TTS
updating steam
restarting steam
restarting my computer
launching TTS without using steam
launching TTS with the "-gl" launch option
launching TTS in developer mode
enabling/disabling public beta mode on TTS
enabling/disabling the FPS counter in steam
launching TTS with the "-nosteam" launch option

The only way to get the game to run is to launch with the option "-nosteam" which allows the game to load but I can't actually play the game since without steam you cannot create or join games (it won't let me do that at least).
Any other suggestions would be appreciated thanks.