Results 1 to 5 of 5

Thread: Avoid "Custom Model" window popup as host when using spawnObject()

  1. #1

    Avoid "Custom Model" window popup as host when using spawnObject()

    Title.

    I've been trying forever to figure it out but I can't.

    Problem 1: "Custom Model" window opens when using spawnObject() (I am giving it a table of parameters)

    Problem 2: The spawned object won't apply my scripted custom parameters until I click "Import". I have a callback function that runs after the custom model has been spawned, that sets all of the custom parameters.

    This is extremely frustrating and any help would be much appreciated.
    Thanks in advance to anyone willing to help!
    Last edited by Errno; 04-22-2016 at 03:07 PM.

  2. #2
    Join Date
    Jul 2015
    Posts
    159
    The window will open if one of the parameters (model, diffuse, etc) is a broken link. Otherwise it should work correctly. It's used in all of our examples.

    Oh, did you call setCustomObject()?

    See here for an example: http://berserk-games.com/knowledgeba...Custom_Objects

  3. #3
    I checked both of the 2 links (model/mesh and diffuse/image) and both of them work.

    And yes I did call setCustomObject() and gave it a table that I got directly by using getCustomObject() on another object. It does copy all of the parameters over but opens the empty window and requires me to re-open and click import. Then the object appears fine.

    I'm just trying to copy an object by re-creating it with the same properties for my own purposes.
    Last edited by Errno; 04-22-2016 at 04:12 PM.

  4. #4
    Join Date
    Jul 2015
    Posts
    159
    Quote Originally Posted by Errno View Post
    I checked both of the 2 links (model/mesh and diffuse/image) and both of them work.

    And yes I did call setCustomObject() and gave it a table that I got directly by using getCustomObject() on another object. It does copy all of the parameters over but opens the empty window and requires me to re-open and click import. Then the object appears fine.

    I'm just trying to copy an object by re-creating it with the same properties for my own purposes.
    That's, bizarre. Anywho, today's patch will include copying and pasting functions. Hopefully they will suit your needs.

  5. #5
    Quote Originally Posted by Dan K View Post
    That's, bizarre. Anywho, today's patch will include copying and pasting functions. Hopefully they will suit your needs.
    Thats a good thing to hear. They most definitely will, thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •