Results 1 to 4 of 4

Thread: Uploading AssetBundle To Cloud Fails - Game Breaking

  1. #1

    Uploading AssetBundle To Cloud Fails - Game Breaking

    I have been playing with uploading asset bundles to TTS in order to get some animated characters for a D&D 3.5 Edition adventure.

    I have tested the asset bundles with the Local option and they all import properly, all the animations work correctly and I am able to script animations.

    Having proven that the asset bundles work, I wanted to upload them to the cloud so that they would work in my multi player game.

    However, when I use the exact same asset bundles with the Cloud option, the asset bundle starts to load and then returns me back to the asset bundle dialog (with actually loading the asset bundle). No error message is displayed.

    Why am I not able to upload the asset bundle to the cloud like other content?

    Note1: I am able to upload OBJ files and texture files to the Cloud...Its just AssetBundles that seem to have a problem for me.
    Note2: I also tried uploading the assetBundle first using Upload Manager. The upload was successful but, once again, when I tried to use the upload link in the assetBundle import it did not import and returned back to the import dialog.
    Note3: I tried using a 3rd party hosting site to host the file. The import still fails. This along with Note 2 leads me to suspect that the hosting is not the problem, it seems to be an issue in the Asset Bundle Import process when used with a cloud based source.
    Last edited by LordAshes; 08-04-2019 at 10:15 PM. Reason: Added additional information

  2. #2

    Uploading AssetBundle To Cloud Fails - Work Around Exists


    I found a way to get it to work. The issue seems to be related with loading the assetBundle into one of my games when I try to import it directly into that game. However, I was able to import the AssetBundle successfully into a empty game and then save the characters as saved objects. This then allowed me to add them to my desired game without getting the above problem.

    As far as I can tell this means there still is some kind of a problem (why would it not import directly into the game) but the above is a easy work-around to get around this problem.

  3. #3
    Thanks ... I just ran into the same problem and would never have figured out that solution.

  4. #4
    BTW, if you would like to bring animated characters into TTS via AssetBundles, I have a step by step video tutorial which teaches how to do that (assuming you don't already know how to do that). It aimed at importing free Mixamo characters but it can be adapted to other sources. The tutorial is a little over 45 minutes but it provides a nice step by step process so that even people who are not so computer knowledgeable should be able to follow it.

    Importing Animated Characters Into TTS Video Tutorial Link:
    Last edited by LordAshes; 08-23-2019 at 01:40 PM. Reason: Provided Link

Similar Threads

  1. Uploading multiple files to the Steam Cloud
    By Unreal_Ed in forum Suggestions
    Replies: 4
    Last Post: 10-01-2018, 04:22 PM
  2. Cast fails to find...
    By cche in forum Scripting
    Replies: 4
    Last Post: 04-12-2018, 12:40 AM
  3. [CRASHES] Crashes when uploading to cloud
    By dcichoracki in forum Technical Support
    Replies: 0
    Last Post: 06-02-2017, 09:06 PM
  4. Replies: 10
    Last Post: 10-30-2016, 05:56 AM
  5. [SOLVED] Custom Table fails to load
    By Aabra in forum Technical Support
    Replies: 5
    Last Post: 09-14-2015, 12:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts